Ask Your Question
0

cant change fedora screen resolution

asked 2018-06-13 11:31:28 -0600

tom342423 gravatar image

ive recently started using fedora and im on the latest version. i only get the option for 800x600 for my resolution and want to change it to 1920x1080 as my laptop screen can support it. thanks in advance

edit retag flag offensive close merge delete

Comments

What is your gpu and graphic driver? It's possible that the driver isn't working or misconfigured. Also could be your monitor sending the wrong EDID info or not sending any at all. On Xorg one can create a custom resolution with randr, no idea on Wayland.

fcomida gravatar imagefcomida ( 2018-06-14 09:59:59 -0600 )edit

The gpu is a gtx1050ti i tried installing the driver with this guide - https://www.if-not-true-then-false.co... . the driver version installed was 390.67 but i had to uninstall it again as during boot up it would hang at started gnome display manager. how would i go about seeing if my monitor is sending wrong EDID? thanks

tom342423 gravatar imagetom342423 ( 2018-06-14 15:14:20 -0600 )edit

@tom342423 I guess the issue is not EDID but the gpu driver. Try reinstalling it after editing /etc/gdm/custom.com. Find the line with WaylandEnable=false and uncomment it. Then after rebooting choose Gnome on Xorg (there's a little gear icon in gdm). Let us know it it works.

fcomida gravatar imagefcomida ( 2018-06-15 06:02:55 -0600 )edit

i edited the custom .conf file but couldnt find the option for choose gnome on xorg. i tried reinstalling the driver anyway but its still freezing at the same point. where would i find gear icon to choose gnome? thanks again

tom342423 gravatar imagetom342423 ( 2018-06-15 08:01:44 -0600 )edit

When (if) gdm starts there's an icon just below the password line-input. The problem though is that gdm isn't even starting. You can boot in text mode, when grub menu shows up press e and move the cursor at the end of the line starting with linux16 or linuxefi and add 3 at the end. Ctrl-x will start booting in text-mode. You'll see a login prompt, enter your username and password. At the bash prompt type startx followd by return. Your Gnome session should start, if instead there's a problem with Xorg you will see a bunch of errors to post here.

fcomida gravatar imagefcomida ( 2018-06-15 12:25:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-16 21:02:25 -0600

abadrinath gravatar image

It's a driver issue that I've had in the past as well.

Try the nouveau driver and the proprietary driver and see which works better for you.

https://www.if-not-true-then-false.co...

(This guide covers both installing Nvidia drivers and the nouveau driver. I recommend trying both as for some people, one works better than others-- less crashing, less glitches, etc. )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-13 11:31:28 -0600

Seen: 285 times

Last updated: Jun 16