Calf LADSPA plugin error in Ardour

asked 2018-06-17 12:05:26 -0500

BrnVrn gravatar image

updated 2018-06-17 14:33:44 -0500

When starting Ardour 5.12.0 on Fedora 28, I always have this error:

[ERROR]: LADSPA: module "/usr/lib64/ladspa/calf.so" has no descriptor function.
[ERROR]: 'ladspa_descriptor': /usr/lib64/ladspa/calf.so: undefined symbol: ladspa_descriptor

Looks like it comes from ladspa-calf-plugins:

$ dnf whatprovides /usr/lib64/ladspa/calf.so
ladspa-calf-plugins-0.90.0-2.fc28.x86_64 : Calf plugins in LADSPA format

Someone used to have the same problem: Bug 1410129: Cannot load calf ladspa plugins

Note Ardour can successfully use lv2-calf-plugins. But it would be nice to get rid of this error.

Part of the problem is that ladspa-calf-plugins are deprecated (Calf only supports LV2) but still required by some dependencies (Guitarix, Flowblade, sox ...)

edit retag flag offensive close merge delete