Ask Your Question
0

How can I disable 'SELinux Troubleshouter' annoying alerts? [closed]

asked 2018-06-23 14:56:16 -0600

Ed Nora gravatar image

updated 2018-06-24 06:56:47 -0600

hhlp gravatar image

Hey there. I am using Fedora distribution from release 26 and since I know in Fedora 28 there is no such application (I mean 'SELinux Troubleshouter') so there is no graphical application to show alerts from SELinux! But the matter that I call 'annoying' alerts is that all of my alerts due to 'snappy' applications while I know there is no full support for snapd packages on SELinux'. One way to ignore all 36 alerts is to ignore all of them one by one but the problem of it, is that after some times all alerts comes again and again and notify me! I am using GNOME desktop and I checked settings> notification to just turn it off but there is SELinux Troubleshooter in it. Any thoughts guy? I'm really confused about that (I searched for it in Google but no luck!) Thanks.

Edit (Answer): According to comments and other answers below, I just tested the @villykruse's way (in the topic's comment) and It's working for me now, Yaaaay! And aeperezt's way should work too. Thank you guys.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by hhlp
close date 2018-06-24 06:56:38.626719

Comments

How about "Would you like to receive alerts?" with a Yes and No selection?

villykruse gravatar imagevillykruse ( 2018-06-23 15:44:17 -0600 )edit

Oops! I didn't notice that before. It was on 'Yes' and I changed it to 'No'. Now the result of that should be appear for next session. Thanks for your comment and I will report if it works so that you may want to change the comment to an answer and I will mark your answer as a correct one for others. Thanks you.

Ed Nora gravatar imageEd Nora ( 2018-06-23 17:55:25 -0600 )edit

Now I restarted session and it seems it's working for me. Thanks.

Ed Nora gravatar imageEd Nora ( 2018-06-24 03:12:48 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-06-23 15:50:06 -0600

villykruse gravatar image

updated 2018-06-24 03:20:18 -0600

Three options:

  • Set "Would you like to receive alerts?" in the `sealert' utility to "No".

  • Edit /etc/selinux/config and disable SELinux completely.

  • Make sure sealert is not running. Gnome seems to have removed that configuration option. So you could remove the utility instead: dnf remove 'setroubleshoot*'

I would not recommend either of these options, and it would be better to use the suggested solutions offered by the sealert utility.

edit flag offensive delete link more

Comments

I think the first option you mentioned is not that good (disabling whole SELinux system just for an graphical noisy application!) And about the second one, If I remove this application, Do I encounter to other issues when there is no application to notify the alert from SELinux to me? (I'm not sure!)

Ed Nora gravatar imageEd Nora ( 2018-06-23 17:58:26 -0600 )edit

AFAIK, sealeart is the only program that notifies you of SELinux issues.

sideburns gravatar imagesideburns ( 2018-06-23 18:49:30 -0600 )edit

Hmmm. I didn't know that. Thanks for your answers.

Ed Nora gravatar imageEd Nora ( 2018-06-24 03:19:55 -0600 )edit

In some desktop environments you can disable the service by creating the file $Home/.config/autostart/sealertauto.desktop with the following contents.

[Desktop Entry]
Hidden=false

I Don't know if that works in Gnome, but it works in XFCE.

villykruse gravatar imagevillykruse ( 2018-06-24 03:24:50 -0600 )edit
0

answered 2018-06-23 21:59:31 -0600

aeperezt gravatar image

Sealert is run as a service by dbus, so you need to disable it there to do so edit as root or with sudo vim /usr/share/dbus-1/system-services/org.fedoraproject.Setroubleshootd.service

which will contain something like:

[D-BUS Service]
Name=org.fedoraproject.Setroubleshootd
Exec=/usr/sbin/setroubleshootd -f 
User=setroubleshoot

Comment out the Exec line that should do the trick

[D-BUS Service]
Name=org.fedoraproject.Setroubleshootd
#Exec=/usr/sbin/setroubleshootd -f 
User=setroubleshoot

After that you need to restart dbus service if you are on a graphical mode Gnome or other best option will be to reboot or logout and login back in, if only if you are on the terminal you could do:

systemctl restart dbus

Good Luck.

edit flag offensive delete link more

Comments

Thanks for your reply. It seems @villykruse's way (in topic's comment) is working for me now, but on the other hand I know your answer is right and it should working well too. If I got any trouble with @villykruse's way I will test your answer. Regards.

Ed Nora gravatar imageEd Nora ( 2018-06-24 03:11:19 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-06-23 14:56:16 -0600

Seen: 254 times

Last updated: Jun 24 '18