Ask Your Question
2

Unable to mount Windows network share

asked 2018-06-24 12:32:35 -0500

Clueless gravatar image

I'm having trouble mounting Windows network share in Fedora 28. Issuing command

   sudo mount -v -t cifs //SERVER-ADDRESS/SHARE/DIRECTORY /home/USER/DIRECTORY -o username="USER",domain="MY-DOMAIN"

gives

   mount.cifs kernel mount options: ip=SRV.IP.ADDR,unc=\\SERVER-ADDRESS\SHARE,user=USER,domain=MY-DOMAIN,prefixpath=DIRECTORY,pass=***
    mount error(22): Invalid argument
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Trying

smbclient -L SERVER-ADDRESS -U 'MY-DOMAIN\USER'

lists shares on the server, but ends with NT_STATUS_INVALID_NETWORK_RESPONSE.

    Sharename       Type      Comment
    ---------       ----      -------
    SHARE           Disk      SHARE DESCRIPTION

 Reconnecting with SMB1 for workgroup listing.
 protocol negotiation failed: NT_STATUS_INVALID_NETWORK_RESPONSE
 Failed to connect with SMB1 -- no workgroup available

On the other hand, when I type in the address smb://SERVER-ADDRESS into the 'Connect to server' box in Gnome Nautilus, everything actually works out of the box - a dialog window asking for username, password and domain appears and connection gets established successfully.

What additional configuration is needed (that is apparently provided for gvfs) to be able to mount the share manually via command line?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-06-28 09:35:27 -0500

Clueless gravatar image

updated 2018-06-28 09:36:26 -0500

As it turned out (and could actually be seen in dmesg output), cifs couldn't choose the right version of SMB. Appending version="2.0" to options in the first command in my question let me succcessfuly mount the share.

edit flag offensive delete link more
1

answered 2018-06-24 18:21:23 -0500

gitman gravatar image

this is what works for me:

sudo mount -t cifs -o username=USER,password=PASS,uid=MYUID //SERVER-IP/SHARE ~/mymountpoint

according to the man page, -o should come before the device and mount point.

edit flag offensive delete link more

Comments

Unfortunately it doesn't solve the problem for me. Still get the same error message.

Clueless gravatar imageClueless ( 2018-06-25 11:31:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-24 12:32:35 -0500

Seen: 1,603 times

Last updated: Jun 28 '18