Ask Your Question
2

Upgrade from fedora 27 to fedora 28 error message in software package.

asked 2018-06-26 09:58:48 -0500

Abdul gravatar image

updated 2018-06-27 06:33:46 -0500

10 days back, I tried to update from Software package and got this message. I did upgraded to Fedora 28 through terminal using DNF and it's works fine, but I didn't understand this message.

Here's the link to the image. You may need to download it to view.

image description

I don't know what does it mean.

Appreciate your help.

Best!!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2018-06-26 10:26:39 -0500

clnetbox gravatar image

updated 2018-06-26 11:10:55 -0500

This can happen from time to time ... but it's nothing to worry about.
It's a temporary connection issue, which mostly disappears by itself.

If you are experiencing the same when running sudo dnf upgrade -
just execute sudo dnf clean all and sudo rm -r /var/cache/dnf.

If this doesn't solve the problem, change from "metalink" to "baseurl".
You can find all relevant .repo files in the /etc/yum.repos.d folder.

An example ... execute : sudo nano /etc/yum.repos.d/fedora.repo

Now you see the # in front of "baseurl" :

[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

Edit the file to have it in front of "metalink" :

[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
baseurl=http://download.fedoraproject.org/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
#metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
enabled=1
metadata_expire=7d
repo_gpgcheck=0
type=rpm
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
skip_if_unavailable=False

Save the change and close the file : press Ctrl + X then Y and then Enter

edit flag offensive delete link more

Comments

It's helpful and I understood it very clearly. Thank you very much.

Abdul gravatar imageAbdul ( 2018-06-26 10:55:40 -0500 )edit

@Abdul : You're welcome ! :) I'm glad that you find it to be useful.

clnetbox gravatar imageclnetbox ( 2018-06-26 11:18:12 -0500 )edit

@Abdul : What I didn't include in my answer (because it wouldn't address your question in first place) is my recommendation to use DNF for software management tasks exclusively - GNOME Software is a front-end to PackageKit which is running side-by-side and known to having some issues every now and then, DNF is much more reliable.

clnetbox gravatar imageclnetbox ( 2018-06-27 05:18:15 -0500 )edit

I didn't know that there are some issues in GNOME Software package and you made it clear. Thank you. I also suggest to use DNF, because it's reliable. I understand it properly.

Abdul gravatar imageAbdul ( 2018-06-27 06:38:26 -0500 )edit
1

answered 2018-06-28 00:54:08 -0500

AkashSolanke gravatar image

Use this command to solve the issue

sudo dnf update

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-06-26 09:58:48 -0500

Seen: 237 times

Last updated: Jun 27 '18