FPS Regression in Kernel 4.17.3

asked 2018-07-01 17:42:40 -0500

steveebey73742 gravatar image

Anyone else notice the drop in fps? shown below are benchmarks of 4.17.2 and 4.17.3. Any suggestions to restore fps would be welcome. I love to have fast performance, since I am not a patient person.

[steve@linuxbox-desktop ~]$ glmark2 --fullscreen (Kernel 4.17.3)
=======================================================
    glmark2 2014.03
=======================================================
    OpenGL Information
    GL_VENDOR:     NVIDIA Corporation
    GL_RENDERER:   GeForce GTX 970/PCIe/SSE2
    GL_VERSION:    4.6.0 NVIDIA 396.24
=======================================================
[build] use-vbo=false: FPS: 3048 FrameTime: 0.328 ms
[build] use-vbo=true: FPS: 6950 FrameTime: 0.144 ms
[texture] texture-filter=nearest: FPS: 6509 FrameTime: 0.154 ms
[texture] texture-filter=linear: FPS: 6495 FrameTime: 0.154 ms
[texture] texture-filter=mipmap: FPS: 6573 FrameTime: 0.152 ms
[shading] shading=gouraud: FPS: 6524 FrameTime: 0.153 ms
[shading] shading=blinn-phong-inf: FPS: 6522 FrameTime: 0.153 ms
[shading] shading=phong: FPS: 6347 FrameTime: 0.158 ms
[shading] shading=cel: FPS: 6365 FrameTime: 0.157 ms
[bump] bump-render=high-poly: FPS: 6048 FrameTime: 0.165 ms
[bump] bump-render=normals: FPS: 7044 FrameTime: 0.142 ms
[bump] bump-render=height: FPS: 6931 FrameTime: 0.144 ms
[effect2d] kernel=0,1,0;1,-4,1;0,1,0;: FPS: 4538 FrameTime: 0.220 ms
[effect2d] kernel=1,1,1,1,1;1,1,1,1,1;1,1,1,1,1;: FPS: 2678 FrameTime: 0.373 ms
[pulsar] light=false:quads=5:texture=false: FPS: 5982 FrameTime: 0.167 ms
[desktop] blur-radius=5:effect=blur:passes=1:separable=true:windows=4: FPS: 1733 FrameTime: 0.577 ms
[desktop] effect=shadow:windows=4: FPS: 1991 FrameTime: 0.502 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 487 FrameTime: 2.053 ms
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=subdata: FPS: 500 FrameTime: 2.000 ms
[buffer] columns=200:interleave=true:update-dispersion=0.9:update-fraction=0.5:update-method=map: FPS: 604 FrameTime: 1.656 ms
[ideas] speed=duration: FPS: 3030 FrameTime: 0.330 ms
[jellyfish] <default>: FPS: 4348 FrameTime: 0.230 ms
[terrain] <default>: FPS: 587 FrameTime: 1.704 ms
[shadow] <default>: FPS: 4729 FrameTime: 0.211 ms
[refract] <default>: FPS: 1650 FrameTime: 0.606 ms
[conditionals] fragment-steps=0:vertex-steps=0: FPS: 6128 FrameTime: 0.163 ms
[conditionals] fragment-steps=5:vertex-steps=0: FPS: 6045 FrameTime: 0.165 ms
[conditionals] fragment-steps=0:vertex-steps=5: FPS: 6091 FrameTime: 0.164 ms
[function] fragment-complexity=low:fragment-steps=5: FPS: 6146 FrameTime: 0.163 ms
[function] fragment-complexity=medium:fragment-steps=5: FPS: 5951 FrameTime: 0.168 ms
[loop] fragment-loop=false:fragment-steps=5:vertex-steps=5: FPS: 6157 FrameTime: 0.162 ms
[loop] fragment-steps=5:fragment-uniform=false:vertex-steps=5: FPS: 6077 FrameTime: 0.165 ms
[loop] fragment-steps=5:fragment-uniform=true:vertex-steps=5: FPS: 5923 FrameTime: 0.169 ms
=======================================================
                                  glmark2 Score: 4749 
=======================================================

[steve@linuxbox-desktop ~]$ glmark2 --fullscreen (Kernel 4.17.2)
=======================================================
    glmark2 2014.03
=======================================================
    OpenGL Information
    GL_VENDOR:     NVIDIA Corporation
    GL_RENDERER:   GeForce GTX 970/PCIe/SSE2
    GL_VERSION:    4.6.0 NVIDIA 396.24
=======================================================
[build] use-vbo=false: FPS: 4732 FrameTime: 0.211 ms
[build] use-vbo=true: FPS: 8387 FrameTime: 0.119 ms ...
(more)
edit retag flag offensive close merge delete

Comments

There were some CPU-related fixes: https://cdn.kernel.org/pub/linux/kern...

Maybe it's one of cpufreq changes, or something Fedora maintainers added in the meantime.

ozeszty gravatar imageozeszty ( 2018-07-14 18:29:46 -0500 )edit

Yes, there were. when i check, my clock is 1400MHz, instead of what it should be, which is 3600MHz. Once I reset the cpufreq, the fps came back. Plymouth does not work on any kernel after 4.17.3 so I will file a bug report for that.

steveebey73742 gravatar imagesteveebey73742 ( 2018-07-15 07:28:01 -0500 )edit

Great, leave some instructions for others with same issue.

ozeszty gravatar imageozeszty ( 2018-07-15 11:20:36 -0500 )edit

here is what works for me, but unfortunately, I have to do this on any 4.17 kernel. When I boot any 4.16 kernel, they are properly set, so something changed between kernels. The numbers are shown here for my processor, so please set the max and min to your processor.

 sudo cpupower frequency-set --max 3600MHz --min 3600MHz
steveebey73742 gravatar imagesteveebey73742 ( 2018-07-15 16:10:58 -0500 )edit

I wouldn't recommend constantly forcing highest clock speed to every user, at least not without pointing out higher power usage, generating more heat and shortening of lifespan.

If you were stuck on 1400 MHz, it would have caused far more severe decrease in score than ~20%. Try playing with different CPU scaling governors, you may achieve even better score (what you did, in theory, should only help if CPU load is to low for scaling governor to ramp up the clocks).

ozeszty gravatar imageozeszty ( 2018-07-15 18:33:17 -0500 )edit