Ask Your Question
0

issue with missing grub uefi

asked 2018-07-03 03:25:01 -0600

ivonenchev gravatar image

updated 2018-07-03 03:58:16 -0600

Hello to all,

I have had an environment with dual boot Windows 10 and Fedora 28. I have a lot of issues with windows 10, so I need to reinstall it. Now I cannot access Fedora, because I don't have any grub. My environment was with uefi boot and Fedora was with lvm.

How can I fix it.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2018-07-03 04:54:25 -0600

clnetbox gravatar image

updated 2018-07-04 03:23:33 -0600

Just reinstall the GRUB boot loader to your EFI partition.
Boot from the fedora Live DVD/USB installation medium.
Once you're on the Live desktop, run these commands :

sudo mount /dev/sdXX /mnt
sudo mount /dev/sdX /mnt/boot/efi
for dir in /dev /proc /sys; do sudo mount --bind $dir /mnt/$dir; done
sudo chroot /mnt

sudo dnf reinstall grub2-efi-x64 shim-x64
sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Notes : sdX = EFI partition | sdXX = system partition
Replace X and XX with your EFI and system partitions.

edit flag offensive delete link more

Comments

The package names have been renamed in fc28 and are grub2-efi-x64 and shim-x64.

villykruse gravatar imagevillykruse ( 2018-07-03 05:15:56 -0600 )edit

You are right - Thank you for the hint @villykruse ! :) I have corrected this accordingly. :) Although, the Fedora 28 System Administration Guide still says grub2-efi and shim - it should be corrected there too.

clnetbox gravatar imageclnetbox ( 2018-07-03 05:24:01 -0600 )edit
0

answered 2018-07-03 04:07:10 -0600

heliosstyx gravatar image

The golden rule for dual-boot with Windows is to install Windows 10 always first (Windows writes ist own Bootloader) and Linux second. I recommend now, if WIndows is running smooth now, make a fresh install of Fedora 28 and all will work fine and it is the fastest way.

edit flag offensive delete link more

Comments

I have already made fresh installation of windows and now I cannot access Fedora, because my fresh installation of windows 10 have removed all records in uefi folder.

ivonenchev gravatar imageivonenchev ( 2018-07-03 04:22:53 -0600 )edit
0

answered 2018-07-04 05:18:21 -0600

David-LDA gravatar image

I just had a nightmare with the latest update in Fedora 28, there is some kind of regression in this new package:

https://bodhi.fedoraproject.org/updat...

To fix it i had to do this: (quoted from this reddit post https://www.reddit.com/r/Fedora/comme...helplatestsmallupdateandtotal_blank/

Basically there has been a fuck up with this up date:

https://bodhi.fedoraproject.org/updat...

It seems some computers (well, mine at least) won't boot any more if they are in the UEFI boot mode (which most will be).

Your mission, should you choose to accept it, is to undo this evil update, and then hunt down the person who approved it and administer a harsh punishment :) Not really. You need to try and boot using the old CSM mode and see if you can get into your computer.

Every BIOS is different, but you should have a 'boot menu', it may be available by pressing F8 on boot, or maybe you need to go into the BIOS and select it. There you can choose what device to boot from. If the Gods are smiling on you there will be 2 entries for your main hard drive, one has UEFI in front of it, the other doesn't. Select the one that DOES NOT and see if it boots. If it does, congratulations, you have defeated the level one boss! If not, afraid you will need to see the other responses in this thread to see the 'hard core' way of doing it. I have not done that, so can't help.

If you can get into the system then go to the bodhi link above, select tab, and you will see a list of files with links. These are the portal to success! Click the first link takes you here:

https://koji.fedoraproject.org/koji/b...

This is the latest BAD version you don't want, you want the last version that worked, so click on 'Package Name' efibootmgr and go here:

Only the files that end fc28 are any good to you, so go to the next newest version:

https://koji.fedoraproject.org/koji/b...

and you want the x86_64 version! This is the tedious manual process you must perform for all the files because the Fedora sudo dnf history undo last command does not seem to hang on to the last version in the cache! Not sure the point of this command if it does jack shit, but it helped me locate the files I needed.

You need to follow the above method to get these files, with the EXACT same names:

shim-x64-13-4.x86_64.rpm
shim-ia32-13-4.x86_64.rpm
fwupdate-efi-10-6.fc28.x86_64.rpm
efivar-34-1.fc28.x86_64.rpm
efibootmgr-15-6.fc28.x86_64.rpm

Maybe its quicker to google them? Anyway, once you have them go into the terminal and type:

sudo dnf install <name of="" package=""> one by one, reboot and pray.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-03 03:25:01 -0600

Seen: 989 times

Last updated: Jul 04