Ask Your Question
0

How can I disable tty terminal time factor for password enterance

asked 2018-07-06 08:52:00 -0500

nokia808 gravatar image

Hi. I'm on Fedora 28. Currently, & since I was on Fedora 24 then 26, tty terminal when I enter username, it will thereafter will ask me to enter password for that account. But when it asking to enter this password, it will give me a time limit that I should enter the password within it. If I did not enter password within this time then it will return back asking me to enter username of account to be login to it.

I dislike this behaviour, because certain time I need more time to remember the password & may enter it wrongly ..... I like to make tty terminal, exactly as GUI terminal already do, wait me for infinite time when it ask me to enter account password.

Best for all !

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-30 06:44:08 -0500

nokia808 gravatar image

You are correct. I have to add following line "LOGIN_TIMEOUT 0" at end of file "/etc/login.defs

sodu vi /etc/login.defs

then at end of file I added:

Login timeout.

LOGIN_TIMEOUT 0

The 1st line started by "#" is totally optional, but it is better to put it.

I'm very afraid from edit system file. So, I wait till confirm solution on many sites before trying it. For that I delayed in applying this fix.

edit flag offensive delete link more
0

answered 2018-07-06 11:43:03 -0500

nokia808 gravatar image

updated 2018-07-06 11:55:10 -0500

villykruse gravatar image

Hi

@villykruse

I run "man login" & read it. I understood that I should edit parameters in file called "/ect/login.defs" I run: vi /etc/login.defs as a user (not root) just to see it's contents. But I did not see the parameters that given !! I saw the following:

#
# Please note that the parameters in this configuration file control the
# behavior of the tools from the shadow-utils component. None of these
# tools uses the PAM mechanism, and the utilities that use PAM (such as the
# passwd command) should therefore be configured elsewhere. Refer to
# /etc/pam.d/system-auth for more information.
#

# *REQUIRED*
#   Directory where mailboxes reside, _or_ name of file, relative to the
#   home directory.  If you _do_ define both, MAIL_DIR takes precedence.
#   QMAIL_DIR is for Qmail
#
#QMAIL_DIR      Maildir
MAIL_DIR        /var/spool/mail
#MAIL_FILE      .mail

# Password aging controls:
#
#       PASS_MAX_DAYS   Maximum number of days a password may be used.
#       PASS_MIN_DAYS   Minimum number of days allowed between password changes.
#       PASS_MIN_LEN    Minimum acceptable password length.
#       PASS_WARN_AGE   Number of days warning given before a password expires.
#
PASS_MAX_DAYS   99999
PASS_MIN_DAYS   0
PASS_MIN_LEN    5
PASS_WARN_AGE   7

#
# Min/max values for automatic uid selection in useradd
#
UID_MIN                  1000
UID_MAX                 60000
# System accounts
SYS_UID_MIN               201
SYS_UID_MAX               999

#
# Min/max values for automatic gid selection in groupadd
#
GID_MIN                  1000
GID_MAX                 60000
# System accounts
SYS_GID_MIN               201
SYS_GID_MAX               999

#
# If defined, this command is run when removing a user.
# It should remove any at/cron/print jobs etc. owned by
# the user to be removed (passed as the first argument).
#
#USERDEL_CMD    /usr/sbin/userdel_local

#
# If useradd should create home directories for users by default
# On RH systems, we do. This option is overridden with the -m flag on
# useradd command line.
#
CREATE_HOME     yes

# The permission mask is initialized to this value. If not specified, 
# the permission mask will be initialized to 022.
UMASK           077

# This enables userdel to remove user groups if no members exist.
#
USERGROUPS_ENAB yes

# Use SHA512 to encrypt password.
ENCRYPT_METHOD SHA512

Any further help please !

edit flag offensive delete link more

Comments

Did you try to append

LOGIN_TIMEOUT 604800

to the end of the file. That should give you 7 days to figure out your password.

villykruse gravatar imagevillykruse ( 2018-07-06 11:58:40 -0500 )edit

Did you try to append this line to the file

LOGIN_TIMEOUT 604800

That should give you one week to figure out your password.

PS: I edited you post to make it readable.

villykruse gravatar imagevillykruse ( 2018-07-06 12:01:14 -0500 )edit

I thing we are in wrong way ! tty terminal do not allow to type password for 2nd time if you type it wrongly in 1st time ! See the following:

https://ask.fedoraproject.org/en/ques...

nokia808 gravatar imagenokia808 ( 2018-07-07 03:53:04 -0500 )edit
0

answered 2018-07-06 09:52:04 -0500

villykruse gravatar image

The answer is in the man page:

man login


CONFIG FILE ITEMS
       login reads the /etc/login.defs(5) configuration file.  Note  that  the
       configuration  file  could  be  distributed  with another package (e.g.
       shadow-utils).  The following  configuration  items  are  relevant  for
       login(1):

 ...

       LOGIN_TIMEOUT (number)
           Max time in seconds for login.  The default value is 60.

       LOGIN_RETRIES (number)
           Maximum  number  of  login  retries in case of a bad password.  The
           default value is 3.
edit flag offensive delete link more

Comments

Hi. I replay you by using "Answer" option because I can not use "comment" option because it's capacity for replay is limited & I did not see parameters when I run:

vi /etc/login.defs

Please to notice my replay & your kind help.

nokia808 gravatar imagenokia808 ( 2018-07-06 11:46:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-06 08:52:00 -0500

Seen: 69 times

Last updated: Jul 30 '18