Ask Your Question
0

Fedora 28 shutdown really slow , Help !

asked 2018-07-10 07:36:08 -0500

Redx1 gravatar image

updated 2018-07-10 07:38:59 -0500

hhlp gravatar image

Hello everyone !

Please i would like to know if there is any way i can make Fedora's shutdown go faster , it takes me minutes of waiting till it shutdown , it's way slower than my previous Fedora 27 , i made a systemd-analyze and this is what i got !

****@localhost ~]$ systemd-analyze
Startup finished in 5.469s (firmware) + 3.461s (loader) + 1.255s (kernel) + 4.099s (initrd) + 54.361s (userspace) = 1min 8.648s
graphical.target reached after 54.352s in userspace

Thank you

edit retag flag offensive close merge delete

Comments

check daemon services , startup applications etc etc .. which needs to be stopped before poweroff .. you can stop some daemon or services which starts automatically with system startup ..

nisankh gravatar imagenisankh ( 2018-07-10 07:46:52 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2018-07-10 10:34:18 -0500

amitosh gravatar image

Here are the usual culprits, check each of them. You will be able to find what is going wrong:

  1. Daemons with expensive shut-down sequences. Are you running any database in local for development?
  2. Virtualization software with active guests. The guests first need to be suspended/shut down.
  3. Running containers. Are you running Docker containers with expensive shut-down sequences (like 1)?
  4. Network mounts which hang.
  5. Some file indexing services (such as KDE's Baloo, GNOME Tracker)
  6. Your WiFi or Bluetooth device which needs a shutdown sequence.
  7. Slow, bog standard disk drive.

Reading the last boot log from journalctl with journalctl -b -0 will contain lines that identify what process is taking too much time to shut down.

edit flag offensive delete link more

Comments

Also there is a bug in systemd preventing unmounting /var and possibly other partitions: https://github.com/systemd/systemd/issues/867

genodeftest gravatar imagegenodeftest ( 2018-07-11 01:47:11 -0500 )edit

This may also be related to decreasing DefaultTimeoutStopSec= in /etc/systemd/system.conf

ssr gravatar imagessr ( 2018-07-13 01:14:30 -0500 )edit
0

answered 2018-07-12 03:01:22 -0500

There are many factors but it also depends on what state of drive you are using , is it SSD , or mechanical hard drive

The boot / Shutdown time depends on several parameters:

    1. The HW of your computer
    2. CPU
    3. Disk (SSD?)
    4. RAM
    5. The software installed on your computer.
    6. Old kernel 
    7. Environment parameters , DE , search paths etc
    8. GRUB features
    9. Priority ( priority of a program )
    10. CPU resources , Memory Resources , I/O resources ( I/O resources like Network , disk etc )
    11. Scheduling processes ( idle , sleep etc )
    12. Cron

Below two minutes time ( shown when you run systemd-analyze or systemd-analyze blame ) is normal

try to run command

sudo systemd-analyze blame

it will show you the culprit in your system if you are facing really slow ( if it is because of applications )

thanks

( firewall services, server app services , userspace etc takes more time, try to clean tmp , cache files etc time to time , use stracer for system optimization and look for service which consumes more time during start/turn off using SYSTEMD-ANALYZE BLAME)

( note : generally SSD drives speed up the process compared to mechanical hard drive )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-10 07:36:08 -0500

Seen: 179 times

Last updated: Jul 12