Ask Your Question
0

On Fedora 27 (workstation) how do I change the desktop to KDE?

asked 2018-07-10 19:09:58 -0600

iliffe gravatar image

I installed Fedora 27 workstation a couple of months ago and find Gnome unusable for a number of reasons. The most serious is that highlight then cut and paste doesn't work at all and my job involves pasting MD5 strings using vi several times a day.

So, I followed the instructions and downloaded KDE but I can't get it to replace Gnome. No option to select the desktop is presented at boot or login time. I ran 'switchdesk' from the command line and it says that KDE is configured to start but reboot provides Gnome again.

How do I get rid of Gnome - preferably permanently!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-10 19:51:03 -0600

abadrinath gravatar image

Check my answer here: https://ask.fedoraproject.org/en/ques...

You might need to replace the yum with dnf. The issue you're facing is gdm(which honestly, I hate too). I would try and mask the service (as I have done in the answer above) to try and fix it.

If you really are having a hard time, get rid of it entirely and uninstall it. You might be sent to a tty temporarily, but you can just reenable a display manager manually yourself (it's lightdm in that answer, but can be any that you choose, including nothing if you just want a tty).

Hope that helps.

edit flag offensive delete link more

Comments

I tried this and it doesn't work. The force-disable works for gdm but even though kde is installed I get the response "Unit file kde.service does not exist". (I tried "kdm" too) I checked the /usr/lib/systemd/system path and there is no kde service listed or any obvious variant.

I checked /usr/sbin (where gdm lives) and even though kde reports as being installed it isn't there; in fact, there is no kde or kdm found by find.

Do you have a sample service file for kde available? And where should kde have been installed? There are lots of kde directories and a config file in /etc

iliffe gravatar imageiliffe ( 2018-07-12 15:31:03 -0600 )edit
0

answered 2018-07-11 03:23:12 -0600

Gaurav29 gravatar image

sudo dnf install @kde-desktop

After the installation of kde, remove gnome by

sudo dnf remove gnome-*

Then restart and enable sddm

systemctl restart sddm

systemctl enable sddm

restarting and enabling sddm is important or else you will stuck in multiuser mode.

Or if you want to run both gnome and kde. When you log in there is a gear icon below the password tab, click on that and select the desired environment you want.

edit flag offensive delete link more

Comments

I tried this with no result. Since I had previously tried to install KDE, it reported that KDE is installed. So I did the restart sddm bit and the screen changed to a random mess of colours. After a while it started alternating back and forth between the boot activity list and the colour screen but never resolved back into a usable screen.

So I rebooted using the hardware reboot and during the boot process I got the notice (twice, everything is listed twice Fedora is booting) "Gnome Desktop Manager started". The gear icon only allows variations of Gnome as choices. Any ideas?

iliffe gravatar imageiliffe ( 2018-07-12 15:09:11 -0600 )edit

Forgot to mention, I have the 4.17.3 kernel that will not boot to a usable screen, so the only way to start a GUI (or command line) is to select the second last kernel. Is this likely to be the reason? If so, any ideas how to backdate the version of Fedora that I'm running?

Gee, I hate Gnome!

iliffe gravatar imageiliffe ( 2018-07-12 15:13:37 -0600 )edit

Yes the gear icon allows variations of gnome. You can do one thing, format your / and root with live cd then, repeat the above steps as I mentioned earlier. Hope this will work.

Gaurav29 gravatar imageGaurav29 ( 2018-07-13 03:42:37 -0600 )edit

I booted from the install CD but, frankly, I'm afraid to reformat the / partition because there is a great deal of my work projects on the machine and I don't want to have to do a recovery. It might not even be possible to recover everything to the current state. The bext solution would be for Fedora to push an update to back out the current Gnome and recover the previous one. That wouldn't solve anything but at least it would boot!

Where does one report the 'show stopper' failures in Fedora? This ranges from not being able to switch desktops to failure of the desktop to appear, etc.

iliffe gravatar imageiliffe ( 2018-07-15 17:58:15 -0600 )edit

Would be great if you can roll back and get the boot. I don't have any idea about the reporting thing. Glad you got your problem solved, atleast a little.

Gaurav29 gravatar imageGaurav29 ( 2018-07-16 00:42:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-10 19:09:58 -0600

Seen: 258 times

Last updated: Jul 11