Ask Your Question
4

freeze in fedora 28 while playing videos

asked 2018-07-17 13:50:25 -0500

boistordu gravatar image

updated 2018-07-20 05:32:25 -0500

So I'm using fedora28 as a bare metal host for a short time now. Besides fedora in qubes OS, I don't use it outside of VMs so I never experienced that.

I'm experiencing complete graphical freeze (ON THE HOST, FEDORA IS NOT IN THE VM) but not sound with videos playing with totem or vlc. The sound continues to play. The only way I can regain control is through a hard reboot. The usb input seems to freeze too because my RGB keyboard is not playing the variation colors during the freezes. Those videos I only have played them from NFS share for the moment. Not tested locally. I can play netflix from firefox without any freezes. the freezes seem to happen randomly during the video. Don't know what triggers it but I can use fedora continuously for days if I don't play videos.

I'm using gnome. So I read that gnome is using wayland, I don't know much about it since I was more used to xorg, but I did the troobleshooting. vlc is using the xorg compatibility of wayland and totem is a native wayland app. So I guess the problem is not in the toolkit nor the app coding, am I right?

So how do I debug this? could it be a problem with mutter? is it a problem with the graphic cards?

I'm using the intel chipset for the moment, I have also a nvidia card installed. I did the installation with the nvidia card linked to the screen and made the change after the installation ... is it the problem ? I know it's stupid mistake. I want to use the nvidia card with gpu passthrough in qemu that's why I went to use the intel chipset.

Gnome or wayland seems to have understood that after 2 reboots after I change cables' places. Should I do something to change a configuration files? is there a way like with xorg to remove the nvidia mention in the system? Before we had to purge the nouveau drivers and look at the xorg configuration, is it a thing alike here?

I really need a help here. Tell me what to show ? or tell me if I need to do a fresh installation with like now the intel chipset as primary in the bios? Or should I do a fresh installation with the nvidia card removed?

Edit 18/07: I've tested with videos locally stored by transfering one from the nfs share to the document folder and still got the freeze around 5 minutes or so after the start of the video.

Edit: config: i7-7700k, 2 screens attached to the igpu intel (on display port and the other one in hdmi). 970 EVGA GTX FTW3 chipset nvidia with one attached screen (gpu passthrough not yet activated) 16G of ram asrock fatality z270 professional gaming ssd intel 730 250G

Edit after test:

It's clearly not a temperature problem. I have ... (more)

edit retag flag offensive close merge delete

Comments

Can you check the system temperature? Does your GPU heat up very much during video playback? The syslog should help getting details (see @suspiciousmilk's answer).

genodeftest gravatar imagegenodeftest ( 2018-07-18 05:18:34 -0500 )edit

I'm going to reinstall the whole thing to check if it's not a wayland bug due to the change of gpu

boistordu gravatar imageboistordu ( 2018-07-18 12:28:53 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-21 16:04:09 -0500

boistordu gravatar image

So as requested on the wayland fedora troobleshooting page, I've made some more test by loading weston (another compositor for wayland maintained by the wayland dev team) and playing videos in it. For the moment after some hours of playing it, no freezes for the moment. I will continue to monitor and delete this answer if it freezes again but as I said before, it's seems to be mutter the problem, the gnome compositor. Does someone know where to send a bug report for mutter?

edit flag offensive delete link more

Comments

1
ncj gravatar imagencj ( 2018-07-23 11:31:41 -0500 )edit
0

answered 2018-07-20 12:12:03 -0500

ncj gravatar image

updated 2018-07-20 12:12:41 -0500

Many users reported that Fedora hangs during read/write operations involving external media under kernel 4.17.4 - 4.17.6.

I had a similar issue.

Try updating your kernel using 4.17.7. If it is not listed as an update you can try it from updates-testing:

sudo dnf update kernel* --enablerepo=updates-testing

More info here:

https://ask.fedoraproject.org/en/ques...

edit flag offensive delete link more

Comments

thanks will try that during my testing but I doubt it's a kernel issue since it's working fine with xorg as I stated before. Plus as I said, it's happening with local copies too. Plus it's not a complete freeze but a freeze of the graphical environment. The disk continues to work, the machine is even reachable through ssh, the sound continues to work. So if it was a kernel panic it would be a complete freeze. This problem does not involve the kernel.

boistordu gravatar imageboistordu ( 2018-07-21 06:42:41 -0500 )edit

That sounds right. The details of your situation were not clear to me from your question.

More generally, in my past experience, GNOME (especially using Wayland) will become unstable after a new update. So I think there is a high probability that you have found the issue in Wayland.

ncj gravatar imagencj ( 2018-07-23 11:31:35 -0500 )edit
0

answered 2018-07-17 20:59:28 -0500

If I understand you correctly (you're kinda all over the place) you are running Fedora 28 from a VM (which one?) and getting freezes when playing videos. That's the jist of it, right?

Your first step in pairing down the problem, would be to log out of Gnome and click the "gear" icon below where you type in your user name and password. Select Gnome on X.org and try playing your videos again. This will determine if this is a problem with Wayland.

You should also take a peek at your log files (there is a log app under utilities) and they could point you in the right direction.

edit flag offensive delete link more
0

answered 2018-07-18 06:20:31 -0500

boistordu gravatar image

No sorry if you misunderstood. Tell me how can I rectify my post ? (by editing I know but which part)

I was saying that I'm using now for a few days only fedora on a bare metal host. Previously I only used in VMs such as qubes. So I never encountered the kind of problems I'm describing now.
That's what I was saying. So my problem here occurs on a bare metal host .

So I have looked at journalctl several times (with which I have another problem too actually but I will do another question for that) but nothing seems transcendent. Can I paste it here? I will try to edit as much as I can to delete the sensitive information.

I'm going to try with xorg yes. And if the problem occurs, I will reinstall I think since I've seen there is no more step to remove or add intel or nouveau graphic driver besides modprobe since everything seems to be centralized now. I will put my configuration in my original post too.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-17 13:50:25 -0500

Seen: 452 times

Last updated: Jul 21 '18