Ask Your Question
2

Bypassing Downgrade Required by Package

asked 2018-07-17 19:28:46 -0500

IchBinAsuka gravatar image

I'm trying to install the Steam package (ala both Negativo17 or RPMFusion) and in this case both repositories require downgraded builds of mesa as a dependency to continue installation. I'm trying out some performance testing in another application which is asking for mesa-git and I would like to maintain it - is there any way I can install the steam package (in this example) while ignoring downgrading dependencies? Does DNF have any arguments that would help with this? If it was done, would other things break? Trying to go the best possible route here. Thanks!

edit retag flag offensive close merge delete

Comments

I'd rather create a bug report at those package sources or their upstream source code. Making you downgrade an essential package is a bad idea, they should update their builds.

genodeftest gravatar imagegenodeftest ( 2018-07-18 04:51:54 -0500 )edit

Is the downgrade of mesa-* going to pull in a ton of other dependency issues? If not then just downgrade iand lock the versions with the dnf version-lock plugin.

boyd gravatar imageboyd ( 2018-07-18 05:05:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-07-18 00:33:24 -0500

abadrinath gravatar image

Take a look at the --skip-broken option; it could help you.

https://dnf.readthedocs.io/en/latest/clivsyum.html#skip-broken

It will skip all broken dependencies. This isn't a great solution as it could 100% break dependencies since versions don't match up with requirements. Other things wouldn't break as long other programs work fine with the newer versions of the two programs. Just Steam could not work, but chances are that it will.

Try it and let us know how it works. There's a solution with rpm as well (--nodeps), I think.

edit flag offensive delete link more

Comments

Agreed that --skip-broken is not a great solution. But it will "0%" break dependencies, since it will just remove (or ignore) packages with dependency issues. It will not create dependency problems. https://dnf.readthedocs.io/en/latest/...

On the other hand rpm -e --nodpes or rpm -i --force will let you remove/add packages and 'ignore' the dependency problems. Maybe you can or can't get away with this, but this will "100%" break dependencies. Your call.

boyd gravatar imageboyd ( 2018-07-18 05:01:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-07-17 19:28:46 -0500

Seen: 70 times

Last updated: Jul 18 '18