Ask Your Question
1

Wifi is not detected

asked 2018-07-19 15:54:54 -0500

Tramp gravatar image

Hello everybody. I have a Dell XPS13 with a broadcom wifi adapter. It worked perfectly, but all of a sudden Network Manager stopped detecting networks. I have no clues about what can be the cause, but when I click on "Connect" in network manager it hangs there forever and does not find any network. As I can regularly connect to the wifi with the same computer when I boot in Windows, the problem is neither the card nor the wifi. Any suggestion?

edit retag flag offensive close merge delete

Comments

I maybe because there was an update of the kernel, therefore the kernel module for your wifi card need to be recompile, try using your machine with older version of the kernel, from the list at boot

aeperezt gravatar imageaeperezt ( 2018-07-19 16:07:46 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-23 13:58:12 -0500

Tom_andreson gravatar image

I am using iMac Pro and I recently started using it. Actually, I can see that the Network Manager is not able to detect the Wi-Fi. It is not finding any network. I tried to contact https://iphonesupport.net/iphone-cust... about this issue. I tried many times to connect but couldn't get rid of this issue. So is there any suggestion available to fix this issue?

edit flag offensive delete link more
0

answered 2018-07-22 03:44:05 -0500

Tramp gravatar image

I don't know what happened, but today the problem seems to be gone. Thanks everybody for the support.

edit flag offensive delete link more

Comments

Anything different you did today compared to yesterday? Can you find out a potential solution for future reference?

abadrinath gravatar imageabadrinath ( 2018-07-23 23:32:48 -0500 )edit
0

answered 2018-07-19 16:46:32 -0500

davidva gravatar image

dkms vrs akmod; ironic... UnitedRPMs maintains a broadcom dkms (broadcom-wl-dkms); Thus I have my Broadcom (BCM43142) working perfectly with the kernel 4.17.6-200. Some underestimate UnitedRPMs; but here exist, hard job... This works for me, and many people ...

edit flag offensive delete link more

Comments

Thank you. It does not seem to be a problem with the kernel: when I boot with an older version (4.16.5-300 as opposed to 4.16.12-300) the problem is still present. I doubt is a problem with akmod: right out of the box, the card was not recognized and I could not see the wifi entry in Network Manager; then I installed broadcom-STA and akmod and after that everything was fine. Now the entry is there -- so the card is recognized -- but it just fails to detect available networks.

Tramp gravatar imageTramp ( 2018-07-20 01:44:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-19 15:54:54 -0500

Seen: 182 times

Last updated: Jul 22