Ask Your Question
1

Unable to write on NTFS mounted file systems in Fedora 28

asked 2018-07-27 03:12:42 -0600

greenz1 gravatar image

updated 2018-07-27 03:52:06 -0600

I installed Fedora in dual boot with Windows 10. The NTFS drives weren't mounted. I had to enter the password everytime I wanted to access some file. This is the default behavior. But I wanted to auto-mount the drives on every boot. So, I opened the /etc/fstab file and added the following line for each of the NTFS partition.

/dev/disk/by-uuid/<mount-uuid> /mnt/MyDrive auto rw,users,exec,uid=my_user_name,gid=my_group_name,permissions,x-gvfs-show 0 0

The drive automounts on each boot but I cannot write in the partitions.

What do I do to get write permissions in the partition?

Some other details

ls -Zdl returns the following

drwxrwxrwx. 1 my_user_name my_group_name system_u:object_r:fusefs_t:s0 4096 Jul 24 12:11 /mnt/MyDrive/

I have tried sudo chown -R my_user_name:my_group_name /mnt/MyDrive/ but it doesn't work.

chcon -R -t svirt_sandbox_file_t /mnt/MyDrive/ returns statements similar to this chcon: failed to change context of 'mathjax.html' to ‘system_u:object_r:svirt_sandbox_file_t:s0’: Read-only file system

I have my reservation and don't want to use sudo chmod 777 /mnt/MyDrive/ but will use it as a last resort.

Thanks for help.

edit retag flag offensive close merge delete

Comments

1

running chmod on an NTFS filesystem does not have any persistent effect. You may want to look at the mount options instead. It looks like you got that right already.

What does ls -al give on a file within the filesystem?

Have you looked at the system log? If mounting a filesystem fails, it sometimes is being remounted ro, i.e. readonly. You may search for ntfs, fuse, mount and readonly in syslog as presented by journalctl -b. Using dmesg may not be enough since NTFS is a userspace filesystem.

genodeftest gravatar imagegenodeftest ( 2018-07-27 05:13:39 -0600 )edit

You may want to try using ntfsls and ntfsmount to get more details.

genodeftest gravatar imagegenodeftest ( 2018-07-27 05:14:06 -0600 )edit

@genodeftest I am reading about those commands

greenz1 gravatar imagegreenz1 ( 2018-07-27 05:43:56 -0600 )edit

1 Answer

Sort by » oldest newest most voted
3

answered 2018-07-27 05:12:00 -0600

villykruse gravatar image

All of chown, chmod, and chcon does not work on windows file systems, including NTFS. And sudo chmod 777 /mnt/MyDrive/ would have not effect either. The permissions for /mnt/MyDrive/ is already 777 (drwxrwxrwx).

What you do need to do is maks sure the windows system is shut down properly, that is, not fast boot, hibernate, sleep or something like that. If the NTFS file system has pending updates when you boot linux, the file system should be mounted in read-only mode to prevent further damage to the file system. Entries in journalctl -b might indicate if this is the case.

edit flag offensive delete link more

Comments

Nothing seems out of order in the journalctl -b. I was on CentOS until now and it worked fine.

Edit: Windows might be the issue. Found this Jul 27 15:54:22 localhost mount[721]: Metadata kept in Windows cache, refused to mount.

greenz1 gravatar imagegreenz1 ( 2018-07-27 05:43:21 -0600 )edit
1

Windows was causing this issue. I used CCleaner to clean all the unnecessary files. Now I can write files. Thanks for answering @villykruse

greenz1 gravatar imagegreenz1 ( 2018-07-27 07:08:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-27 03:12:42 -0600

Seen: 999 times

Last updated: Jul 27 '18