Ask Your Question

Problem using dnf and yum on Fedora 28

asked 2018-08-07 11:31:12 -0500

fsrgio gravatar image


I need some help i am using Fedora 28 workstation but i can use dnf nor yum.

I am getting this error:

Failed to sync cache to 'update' repository


sudo dnf check-update -C

Cache-only enabled but no cache for update

Same thing when i tried to install authconfig-gtk using yum

sudo yum -y install authconfig-gtk sssd krb5-workstation

Error: Failed to synchronize cache for repository 'update'

How can i solve this?

PS: error messages were translated from my native language so the messages may be different.

Thank you

edit retag flag offensive close merge delete



Run export LC_ALL=C and your next commands will display English text. After you log out you will be back to your original language setting.

villykruse gravatar imagevillykruse ( 2018-08-07 14:39:57 -0500 )edit

This problem usually happens if there is either a problem with your internet connection or with the server or mirrors dnf is trying to download metadata information from.

Try a sudo dnf clean all followed by a sudo dnf update.

If that doesn’t solve the problem, simply wait a few hours and everything should be back to normal.

florian gravatar imageflorian ( 2018-08-07 15:03:50 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2018-08-08 04:01:27 -0500

fsrgio gravatar image

Thank you for your answers. It is related to my company network that is blocking me from using this commands. If i use them at home they both work.

edit flag offensive delete link more



humm... maybe your are behind a proxy in your company -> edit /etc/dnf/dnf.conf and add below lines :

hhlp gravatar imagehhlp ( 2018-08-08 04:20:33 -0500 )edit

How can i find out my proxy? Does it show if i use ifconfig -a?

fsrgio gravatar imagefsrgio ( 2018-08-13 11:43:46 -0500 )edit

@fsrgio if you have problem in your company you have got to contact with your company network administrator to get detils about your company network configuration

hhlp gravatar imagehhlp ( 2018-08-13 12:52:04 -0500 )edit

@hhlp Done. Thank you very much. it's now perfectly working

fsrgio gravatar imagefsrgio ( 2018-08-14 05:43:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-08-07 11:31:12 -0500

Seen: 461 times

Last updated: Aug 08 '18