Ask Your Question
1

Is this a bug or have I done something wrong?

asked 2018-08-21 20:47:18 -0500

grgoffe gravatar image

updated 2018-08-22 04:21:50 -0500

hhlp gravatar image

Hi,

I have a fedora29 (x86_64) system and am trying to upgrade from the (more or less) current rawhide repository. I typically don't do too much "creat ive" dnf or rpm work on this system. I'm now trying to upgrade this system and am receiving messages that I have never seen before and am not quit e able to find out what I need to do to rectify the problem.

Could someone take a look at these messages (below) and help me with this please?

Regards and thanks,

George...

/usr/bin/dnf --skip-broken  upgrade -v
Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repocl
osure, repograph, repomanage, reposync
DNF version: 3.2.0
cachedir: /var/cache/dnf
repo: using cache for: rawhide-modular
not found deltainfo for: Fedora - Modular Rawhide - Developmental packages for the next Fedora release
not found updateinfo for: Fedora - Modular Rawhide - Developmental packages for the next Fedora release
rawhide-modular: using metadata from Fri 17 Aug 2018 01:17:52 AM PDT.
repo: using cache for: rawhide
not found deltainfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
not found updateinfo for: Fedora - Rawhide - Developmental packages for the next Fedora release
rawhide: using metadata from Fri 17 Aug 2018 01:17:28 AM PDT.
repo: using cache for: google-earth
not found deltainfo for: google-earth
not found updateinfo for: google-earth
google-earth: using metadata from Fri 10 Aug 2018 01:40:58 PM PDT.
repo: using cache for: opera
not found deltainfo for: Opera packages
not found updateinfo for: Opera packages
opera: using metadata from Mon 20 Aug 2018 01:00:38 AM PDT.
Last metadata expiration check: 0:23:36 ago on Tue 21 Aug 2018 02:35:01 PM PDT.
Missing file *modules.yaml in metadata cache dir: /var/cache/dnf/rawhide-2d95c80a1fa0a67d
Missing file *modules.yaml in metadata cache dir: /var/cache/dnf/google-earth-17f28a61f303b7a2
Missing file *modules.yaml in metadata cache dir: /var/cache/dnf/opera-4e999c6fc4466cf1
--> Starting dependency resolution
--> Finished dependency resolution
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package container-selinux-2:2.69-1.git452b90d.fc29.noarch
  - package container-selinux-2:2.69-3.git452b90d.module_2106+3b446c4f.noarch is disabled
 Problem 2: cannot install the best update candidate for package containernetworking-cni-0.7.1-1.fc29.x86_64
  - package containernetworking-cni-0.7.1-1.module_2106+3b446c4f.x86_64 is disabled
 Problem 3: cannot install the best update candidate for package kubernetes-client-1.10.3-1.fc29.x86_64
  - package kubernetes-client-1.10.3-1.module_2097+0ff3e838.x86_64 is disabled
 Problem 4: cannot install the best update candidate for package oci-systemd-hook-1:0.1.17-3.gitbd86a79.fc29.x86_64
  - package oci-systemd-hook-1:0.1.17-3.gitbd86a79.module_2106+3b446c4f.x86_64 is disabled
Problem 5: cannot install the best update candidate for package origin-clients-3.10.0-1.fc29.x86_64
  - package origin-clients-3.10.0-1.module_2019+a172361f.x86_64 is disabled
 Problem 6: cannot install the best update candidate for package perl-DB_File-1.842-1.fc29.x86_64
  - package perl-DB_File-1.842-1.module_2073+eebc5b71.x86_64 is disabled
 Problem 7: cannot install the best update candidate for package perl-HTTP-Tiny-0.076-1.fc29.noarch
  - package perl-HTTP-Tiny-0.076-1.module_2073 ...
(more)
edit retag flag offensive close merge delete

Comments

Aeyoun gravatar imageAeyoun ( 2018-09-14 07:16:48 -0500 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2018-08-22 05:01:21 -0500

villykruse gravatar image

Rawhide was switched over to becomd fedora a few days ago. So what I did was

  • disable all repos found in /etc/yum.repos.d

  • enable the fedora.repo

  • run dnf clean all

  • run dnf update 'fedora*'

This will re-install the repository files in /etc/yum.repos.d and thereby enabling the fedora and updates repositories. Doing this should enable you to upgrade to fc29beta.

edit flag offensive delete link more

Comments

Villy,

Thanks for your suggestions. They worked great!

I also ran genodeftest's suggestions but ran into some problems with "dnf remove --duplicates".

There's more info in bugzilla.redhat.com, bug-id 1615060. I'm not sure whether the below is a part of this bug-id or is a new bug.

Thanks.

Error: Transaction check error:
  file /usr/lib64/libssh.so.4 from install of libssh-0.8.1-4.fc30.x86_64 conflicts with file from package libssh-0.8.0-1.fc29.x86_64
  file /usr/share/doc/libssh/ChangeLog from install of libssh-0.8.1-4.fc30.x86_64 conflicts with file from package libssh-0.8.0-1.fc29.x86_6
grgoffe gravatar imagegrgoffe ( 2018-08-22 14:50:07 -0500 )edit

You should keep libssh-0.8.0-1.fc29.x86_64. The package libssh-0.8.1-4.fc30.x86_64 is from the future fc30 version and would come from rawhide.

Tip: for formatting your post: Select your pasted lines and hit the "01010101" buttom. Fixed it for you.

villykruse gravatar imagevillykruse ( 2018-08-23 00:34:01 -0500 )edit
0

answered 2018-08-22 05:47:24 -0500

genodeftest gravatar image

In addition to @villykruse's answer, these commands may help getting your system back to "normal":

  • dnf distro-sync
  • dnf repoquery --unsatisfied
  • dnf repoquery --duplicated
  • dnf list extras – this one may contain useful packages, don't remove all of them blindly
  • package-cleanup, see its --help page for details
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-21 20:47:18 -0500

Seen: 545 times

Last updated: Aug 22 '18