Fix Grub so it can Automatically Boot

asked 2018-08-25 09:04:33 -0500

FedoraUser2018 gravatar image

Hello,

I have been using Fedora 28 since June. I have a Windows 10 and Fedora 28 dual boot laptop (Dell Latitude 5580).

After upgrading Fedora 28 to the newest kernel a couple weeks into June, I restarted the computer. When grub came up, I selected Windows because that's what I needed to use at the time. When I rebooted, it went to the "dreaded grub2 prompt" (as seen in Fedora 28 documentation).

I've been doing the following to boot my computer for the past couple of weeks:

ls
ls (hd1,gpt4)/
set prefix=(hd1,gpt4)/grub2
set root=(hd1,gpt4)
insmod normal
normal

That allows me to see a normal grub menu and select Windows 10 or Fedora 28.

I've tried reinstalling grub2 to fix the issue, but it still boots to the grub prompt. I did this a while ago to no avail: sudo dnf reinstall grub2-efi-x64 shim-x64 sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Then, I rebooted and still got the grub2 prompt instead of the normal menu.

That's the last I've tried to fix it. I've been dealing with typing in those same commands almost everytime I open my laptop, and I'm finally getting tired of it.

Why do I have to run these commands everytime? Can anyone help me run them automatically evertime or remove the need to use them?

edit retag flag offensive close merge delete