Ask Your Question
1

i can`t install driver RTL8814au in fedora28 (solved)

asked 2018-08-26 13:46:48 -0500

devrieshh gravatar image

updated 2018-09-04 11:15:15 -0500

i am trying to install a edup usb wireless adapter model EP-AC1621
every thing went well,exept building ,see command sudo dkms build -m rtl8814au -v 4.3.21below. the command should work with the 4.15kernel. i use 4.19.0-0.rc0.git9.2.fc30.x8664 now. My working network,with driver=rtl8192cu workes untill the 4.18kernel so i have to startup with kernel 4.18 for internet access. I cant find a solution yet for this 4.19 kernel . hope somebody has find a solution,thanks in advance.

iwconfig
enp2s0    no wireless extensions.

wlp0s19f2u1  IEEE 802.11bgn  ESSID:"HT37Pro"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.417 GHz  Access Point: 02:03:AC:1F:6F:13   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=94/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

virbr0-nic  no wireless extensions.

virbr0    no wireless extensions.

lo        no wireless extensions.

virbr0-nic is the edup adapter 



lshw -C network
  *-network                 
       description: Ethernet interface
       product: AR8151 v2.0 Gigabit Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: c0
       serial: d0:50:99:92:4c:85
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.1-NAPI latency=0 link=no multicast=yes port=twisted pair
       resources: irq:24 memory:febc0000-febfffff ioport:e800(size=128)
  *-network:0
       description: Wireless interface
       physical id: 1
       bus info: usb@2:1
       logical name: wlp0s19f2u1
       serial: 60:e3:27:1c:9c:bf
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192cu ip=192.168.43.222 multicast=yes wireless=IEEE 802.11bgn
  *-network:1 DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: virbr0-nic
       serial: 52:54:00:a7:2a:16
       size: 10Mbit/s
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=tun driverversion=1.6 duplex=full link=no multicast=yes port=twisted pair speed=10Mbit/s





sudo dkms build -m rtl8814au -v 4.3.21

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area...
'make'..............(bad exit status: 2)
Error! Bad return status for module build on kernel: 4.19.0-0.rc0.git9.2.fc30.x86_64 (x86_64)
Consult /var/lib/dkms/rtl8814au/4.3.21/build/make.log for more information.


DKMS make.log for rtl8814AU-1.0 for kernel 4.19.0-0.rc0.git9.2.fc30.x86_64 (x86_64)
zo 26 aug 2018 20:11:05 CEST
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.19.0-0.rc0.git9.2.fc30.x86_64/build M=/var/lib/dkms/rtl8814AU/1.0/build  modules
make[1]: Map '/usr/src/kernels/4.19.0-0.rc0.git9.2.fc30.x86_64' wordt binnengegaan
  CC [M]  /var ...
(more)
edit retag flag offensive close merge delete

Comments

Same problem with kernel >= 4.15 as reported here (a different realtek chip). Google a bit to see if there are patches around, if you have some C programming skills you can try to adapt the patch in the link above.

fcomida gravatar imagefcomida ( 2018-08-26 14:27:48 -0500 )edit

Thanks,i will try that

devrieshh gravatar imagedevrieshh ( 2018-09-03 06:16:57 -0500 )edit

I am also trying the same thing and install wireless adapter model EP-AC1621 but I can't, after that, I take a help of Hp Support Assistant to solve out my issue but I can't do the thing properly, can anyone guide me?

jhon0009 gravatar imagejhon0009 ( 2018-09-06 18:01:22 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-09-04 10:53:50 -0500

devrieshh gravatar image

updated 2018-09-06 13:25:52 -0500

after downgrading to 4.17.200 and installing all the kernel modules....

[root@localhost rtl8814au-4.3.21]# dkms build -m rtl8814au -v 4.3.21

Kernel preparation unnecessary for this kernel. Skipping...

Building module: cleaning build area... 'make'.................................... cleaning build area...

DKMS: build completed. [root@localhost rtl8814au-4.3.21]# dkms install -m rtl8814au -v 4.3.21

8814au.ko.xz: Running module version sanity check. - Original module - No original module exists within this kernel - Installation - Installing to /lib/modules/4.17.19-200.fc28.x86_64/extra/ Adding any weak-modules

depmod.....

Backing up initramfs-4.17.19-200.fc28.x8664.img to /boot/initramfs-4.17.19-200.fc28.x8664.img.old-dkms Making new initramfs-4.17.19-200.fc28.x8664.img (If next boot fails, revert to initramfs-4.17.19-200.fc28.x8664.img.old-dkms image) dracut............

DKMS: install completed. [root@localhost rtl8814au-4.3.21]#

SOLVED!!!!

The edup 11AC 1900M Dual-Band USBV 3.0 wireless Adapter workes...

Solution, Install the kernel modules downbelow...

yum install kernel-tools-libs-devel-4.17.19-200.fc28.x8664 yum install kernel-tools-4.17.19-200.fc28.x8664 yum install kernel-modules-extra-4.17.19-200.fc28.x8664 yum install kernel-devel-4.17.19-200.fc28.x8664 yum install kernel headers-4.18.0-0.rc7.git1.2.fc29.x8664 yum install kernel-core-4.17.19-200.fc28.x8664

thanks for the help

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-08-26 13:46:48 -0500

Seen: 787 times

Last updated: Sep 06 '18