Ask Your Question
1

how to disable pageup key

asked 2018-09-02 00:12:39 -0600

shafeequemhd gravatar image

I have my laptop keyboard a bit old and my pageup key is damaged. hence this key works itself continuously creating problems even while opening fedora. is there a way to disable this key alone? or changing key board is the only solution?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2018-09-02 19:09:59 -0600

ed209 gravatar image

If you use X then xmodmap is your friend:

xmodmap -e 'keycode 112 = '

to disable PageUp key.

Under Wayland I don't know.

edit flag offensive delete link more

Comments

It'll take a good bit of poking around in Wayland to figure out how to do this. As per this thread on askubuntu, Wayland still uses X keyboard layout files but you don't have nice utilities to remap specific keys. You'll have to find whichever layout you're using and edit that file to remove the reference to pgup. The key is referenced as "PGUP" in each file, so use that to narrow down the possible files to modify.

bob323 gravatar imagebob323 ( 2018-09-04 21:47:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-09-02 00:12:39 -0600

Seen: 37 times

Last updated: Sep 02