Unable to use OpenGL for QEMU virtual machines

asked 2018-09-04 22:03:35 -0500

bob323 gravatar image

updated 2018-09-04 22:04:18 -0500

I'm using virt-manager to set up an Ubuntu guest. I'd like to use OpenGL with it, but I can't seem to get it configured correctly.

By default, the machine is set up with QXL video (not sure what a more technical description of this is, since it just shows "Video QXL" in the virt-manager menu). Under "Display Spice," there's a checkbox for OpenGL with a warning icon next to it. Hovering over the warning icon gives a message: "Spice GL requires virtio graphics configured with accel3d."

Under "Video QXL," I'm able to change the model to "Virtio," at which point a checkbox titled "3D acceleration" appears. If I check this box, then return to "Display Spice," the warning icon is still there next to the OpenGL checkbox. Hovering over it gives a new warning message: "Graphics listen type does not support spice GL." There's a menu next to "Listen type:" with "Address" selected. The only other option is "None," which also apparently doesn't support spice GL. So neither available listen type works.

Is there a way to get OpenGL working?

edit retag flag offensive close merge delete