Ask Your Question
0

I cannot get Spotify to install

asked 2018-09-08 14:40:48 -0500

updated 2018-09-09 10:34:02 -0500

genodeftest gravatar image

Hi, I just installed Fedora 28 on to my Lenovo X1, and I'm trying to get Spotify to run. I keep getting the following message:

The Application eu.tiliado.NuvolaAppSpotify/x86_64/stable requires the org.gnome.Platform/x86_64/3.28 which was not found

What do I need to do? I like Fedora so far but I need my Spotify.

edit retag flag offensive close merge delete

Comments

Run your system updates and try again. It's saying you don't have Gnome installed, did you use the default Fedora or a Spin?

You could also got to folkswithhats.org and follow those instructions to install Fedy. Fedy is an app that gives you access to one-click-installs of many applications/tweaks/themes/utilities that are popular and/or are normally harder to install for new users. Spotify is one such app with a single-click-install.

suspiciousmilk gravatar imagesuspiciousmilk ( 2018-09-08 20:35:22 -0500 )edit
2

This sounds like you are running Spotify as flatpak from flathub, right? How did you install it?

florian gravatar imageflorian ( 2018-09-08 22:06:46 -0500 )edit

I was trying to install it via these instructions: https://nuvola.tiliado.eu/app/spotify...

It kept telling me that The Application eu.tiliado.NuvolaAppSpotify/x8664/stable requires the org.gnome.Platform/x8664/3.28 which was not found

I do have GNOME, I did a standard install

supersayianreagan gravatar imagesupersayianreagan ( 2018-09-09 07:58:02 -0500 )edit

I installed Fedy and was able to get Spotify to run. However, I am curious why the other means didn't run and what that message means.

supersayianreagan gravatar imagesupersayianreagan ( 2018-09-09 08:21:39 -0500 )edit

@florian: Is this a bug in flatpak? Should it not install dependencies automatically?

genodeftest gravatar imagegenodeftest ( 2018-09-09 10:35:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-09-09 02:45:29 -0500

Rabin gravatar image

seems like you installed Spotify as flatpak, but didn't install it dependences, run this command to install the missing packages

flatpak install flathub org.gnome.Platform/x86_64/3.28
edit flag offensive delete link more

Comments

I got the following when I attempted that: Unable to load summary from remote flathub: GPG verification enabled, but no signatures found (use gpg-verify=false in remote config to disable)

supersayianreagan gravatar imagesupersayianreagan ( 2018-09-09 08:20:38 -0500 )edit
1

Did you run

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

before?

Also, check out: https://flathub.org

florian gravatar imageflorian ( 2018-09-09 13:56:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-09-08 14:40:48 -0500

Seen: 166 times

Last updated: Sep 09 '18