Ask Your Question
1

Fedora 28 KDE spin qt 5.10.x

asked 2018-09-12 09:44:12 -0600

heliosstyx gravatar image

updated 2018-09-12 09:45:27 -0600

Why does Fedora 28 KDE spindoes not update QT 5.10.x to QT5 5.11.x automatically? Please give me some reasons. Thanky you.

edit retag flag offensive close merge delete

Comments

2

Instead of closing a question with a correct answer, this forum wants users to mark the correct answer using the tick mark above the up/downvote buttons. (I know it's confusing, especially since that reason for closing exists in the askbot software.)

Reopening ...

florian gravatar imageflorian ( 2018-09-12 15:33:33 -0600 )edit

Please show where to do it correctly

heliosstyx gravatar imageheliosstyx ( 2018-09-13 04:21:09 -0600 )edit

Click on the grey check mark...

florian gravatar imageflorian ( 2018-09-13 08:35:10 -0600 )edit

I see no grey checkmark. Please do it for me, you can also reopen my question.

heliosstyx gravatar imageheliosstyx ( 2018-09-13 09:37:22 -0600 )edit

I see a green check mark now. You must have found it. (Only the user asking the question can mark an answer as the correct one)

florian gravatar imageflorian ( 2018-09-13 10:31:41 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2018-09-13 10:39:15 -0600

florian gravatar image

updated 2018-09-13 10:50:36 -0600

Someone filed a bug about the qt problem and a new build (2018.1.1-2) has been released in Fedora's repos (as of today, it's in testing).

I would suggest you remove the "old" 2017 version that you installed from a third-party and instead install FlightGear from Fedora's repo.

As long as it is in testing, sudo dnf install --enablerepo=updates-testing FlightGear

See https://bodhi.fedoraproject.org/updat... and https://apps.fedoraproject.org/packag...

edit flag offensive delete link more
1

answered 2018-09-12 14:42:49 -0600

heliosstyx gravatar image

The inhibitor for updating to qt 5.11 was FlightGear 2018.xx, the dependencies of FlightGear try to install qt 5.10 etc. The solution is to use FlightGear 2017.xx and now the system is up-to-date.

edit flag offensive delete link more

Comments

after updating to qt 5.11, is FlightGear fine with updating to version 2018.1.1 from the F28 repos?

florian gravatar imageflorian ( 2018-09-12 15:33:22 -0600 )edit

Look here: https://fedora.pkgs.org/28/fedora-upd...64/FlightGear-2018.1.1-1.fc28.x8664.rpm.html here you can see that FlightGear pulls in some qt 5.10.xx. files That is the same as I described. No other Version available in Fedora's repos. 2018.2.2 is only available on Fedora 29 rawhide, there is no more qt 5.10.xx reference. What's About Fedora 29 rawhide, please can you explain me?

heliosstyx gravatar imageheliosstyx ( 2018-09-13 04:38:36 -0600 )edit

I would not suggest installing software from outside Fedora's official software repositories if the software is available within the repos.

Both Flightgear 2018.2.2 and 2018.1.1 have now been built for qt5.11 (see my answer below).

florian gravatar imageflorian ( 2018-09-13 10:43:06 -0600 )edit
1

answered 2018-09-12 12:22:54 -0600

florian gravatar image

updated 2018-09-13 00:31:28 -0600

genodeftest gravatar image

Is dnf update sayting something like this

=====================================================================================
 Package                       Arch                Version                Repository         Size
=====================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 qt5-qtbase                    x86_64              5.11.1-7.fc28          updates           3.3 M
Skipping packages with broken dependencies:
 python2-qt5                   x86_64              5.10.1-4.fc28          updates            1.2 M
 python2-qt5-base              x86_64              5.10.1-4.fc28          updates            2.7 M
 python3-qt5                   x86_64              5.10.1-4.fc28          updates            1.2 M

Transaction Summary
=====================================================================================
Skip  4 Packages

Nothing to do.

?

That usually means that you have another package installed that is depending on the qt-5.10.x package. You have to wait for that package to be updated, or you remove it and thus removing the dependency on the older qt5 package(s).

FYI: I have something similar going on, in my case qgis needs qt5-qtbase-5.10.1-6.fc28.x86_64 (libQt5Core.so.5(Qt_5.10.1_PRIVATE_API). See here for details. Maybe your dnf update is telling you something simiar.

edit flag offensive delete link more

Comments

Thank you Florian. In my case it is FlightGear newest version. In my case dnfdragora wants to downgrade FlightGear.

heliosstyx gravatar imageheliosstyx ( 2018-09-12 12:41:23 -0600 )edit

FlightGear rocks - I am playing it myself (or I used to play it but don't find the time for it currently). Not sure you need qt5.11 for anything. Also, not sure why an earlier version of FlightGear would not require the same or even an older qt.

florian gravatar imageflorian ( 2018-09-12 13:05:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-09-12 09:44:12 -0600

Seen: 136 times

Last updated: Sep 13