Ask Your Question
1

Steam install Fedora 28 fail

asked 2018-09-13 23:50:26 -0600

When I try to install via the rpmfusion-nonfree-steam it wants to reinstall 170 packages in 32-bit which are mostly system packages. If I type --skip-broken it fails to install Steam. If I put --allowerasing Steam won't launch. Is it necessary to install all the 32-bit packages?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-09-14 04:33:43 -0600

villykruse gravatar image

As steam from rpmfusion is compiled as a 32-bit program it would need these 32-bit libraries.

[root@mybox ~]# dnf list steam\*
Last metadata expiration check: 3:03:02 ago on Fri 14 Sep 2018 08:27:03 CEST.
Available Packages
steam.i686              1.0.0.54-18.fc28               rpmfusion-nonfree-updates
[root@mybox ~]#

Notice it says ".i686" which means it is a 32-bit package.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-09-13 23:50:26 -0600

Seen: 554 times

Last updated: Sep 14