How to change libinput's mouse acceleration on Fedora 28 KDE?

asked 2018-09-27 20:32:59 -0600

tehabstract gravatar image

So I tried setting the properties for acceleration in xinput but I get:

property 'libinput Accel ...' doesn't exist, you need to specify its type and format, only properties that exist are:

    libinput Accel Speed (298):     -0.110000
    libinput Accel Speed Default (299):     0.000000
    libinput Accel Profiles Available (300):        1, 1
    libinput Accel Profile Enabled (301):   1, 0
    libinput Accel Profile Enabled Default (302):   1, 0

I manage to do it with set-float-prop but I don't see any change..

I tried using these settings: Arch Wiki But to no avail.

Xset is also not doing anything, as well as xinput set-ptr-feedback on the mouse.

Is there anything special that I need to do, I tried using extreme values so I can see the difference, nothing works?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

Yeah I know about this setting window, but from what I know there are more settings about accel that can be set?

tehabstract gravatar imagetehabstract ( 2018-09-30 09:59:42 -0600 )edit

Is there any way I can set AdaptiveDeceleration, AccelerationNumerator, etc? When I try to set prop for example 'libinput Accel Acceleration Numerator' i get: property 'libinput Acceleration Numerator' doesn't exist, you need to specify its type and format, I can set it as set-float-prop, but I do not feel the difference at all even when using really high values? I really want to only make it "exponentional" like in Windows? ( I got used to Windows' 'Enable pointer precision', and I wanna game on Fedora )

tehabstract gravatar imagetehabstract ( 2018-09-30 14:22:16 -0600 )edit