Ask Your Question
1

Install Fedora 28 on Lenovo Legion y530s

asked 2018-10-12 14:21:18 -0500

JollyDev gravatar image

I am currently trying to install Fedora 28 on my brand new Lenovo Legion y530s. I currently have Windows 10 loaded, and am open to either a dual-boot environment, or strictly Fedora, whichever is easier at this point. My problem is that any time I try to install from live USB, Fedora does not detect any hard disk. I suspect this has something to do with my existing Windows 10 installation on a 1TB HDD + 25GB SSD (Intel Octane). I am guessing that my trouble is that Fedora may be recognizing my disks as RAID setup due to the Octane setup. I have tried:

Both Legacy BIOS and UEFI - Neither worked Changing from RST to AHCI mode Disabling Secure Boot Using Windows Disk Management to shrink the Windows partition - hoping that the free space would show up - no such luck when I left it unformatted or after formatting to NTFS Enabling and disabling Intel Virtual Technology (VM) - I can't imagine this has anything to do with it but I have tried it.

I have scoured the internet for the better part of the day, and can find no help to my issue. I am open to possibly a different distro than Fedora, but Fedora is BY FAR my most preferred distro. Any help would be greatly appreciated. Please let me know what other info you might need from me to help diagnose my issue.

edit retag flag offensive close merge delete

Comments

Hi, I don't have any experience with Optane memory, but, I guess, switching to AHCI and maybe disabling Optane cache'ing (if in BIOS there are any storage related settings, other then RST/AHCI) and then formatting HDD and SSD, should make them visible for Anaconda.

If you boot live USB with Fedora, what does fdisk -l outputs?

ozeszty gravatar imageozeszty ( 2018-10-12 17:15:47 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-10-13 19:39:44 -0500

JollyDev gravatar image

Thanks ozeszty. Your comment about disabling Optane cacheing made me think there might be somewhere else to disable it, as I could only find it in BIOS/UEFI under Intel RST, and disabling it there had not worked.

I now have it working! The step I missed was actually logging into the windows installation, finding the program Intel Optane Memory, and disabling the cacheing from within the program. After doing that, I was able to switch to AHCI instead of RST in the BIOS, and low and behold, fedora detected my hard disk! Thanks so much for your help! Hope this can help others!

edit flag offensive delete link more

Comments

Great, you should be able to use Optane with Fedora, to speed it up. Right now you probably have there some hibernation partition making windows hibernate faster, you could delete it to get more space (~32 GB). You can install / on it (and /home on HDD) or, if you need more space for /, create LVM Volume Group on both disks and use combined free space.

ozeszty gravatar imageozeszty ( 2018-10-14 07:19:20 -0500 )edit

Well, I guess I got prematurely excited. After installing, I can't boot into Linux. After entering encryption password, everything loads up to the point "starting gnome display manager". After this I get a black screen and a frozen mouse cursor, frozen everything, and have to hard reset the computer. No matter how many times I do this, it does the same thing. I have tried pressing "e" to edit boot options and adding nomodeset after quiet, deleting quiet, all to no avail. My guest for Fedora continues lol.

After researching, I think it may be something to do with the Nvidia graphics card have

JollyDev gravatar imageJollyDev ( 2018-10-14 18:14:02 -0500 )edit

Start a new question with more installation and hardware details.

ozeszty gravatar imageozeszty ( 2018-10-15 02:58:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-12 14:21:18 -0500

Seen: 428 times

Last updated: Oct 12 '18