Ask Your Question
0

Plasma Discover/Flatpak Update Question

asked 2018-10-17 10:49:16 -0500

JollyDev gravatar image

updated 2018-10-17 12:19:31 -0500

hhlp gravatar image

I have been scouring the internet trying to find an answer to this question.

I currently have a pretty fresh install of the Fedora 28 KDE spin. I was having some issues getting the gnome environment to load on this system, and so I'm taking the KDE environment for a test drive.

Everything seems to be going ok so far, but after trying to install some recent software updates (via the Software Update program OR via Terminal), I am continually getting the following error:

Error running transaction: file /usr/lib64/qt5/plugins/discover/flatpak-backend.so from install of plasma-discover-flatpak-5.13.5-1.fc28.x86_64 conflicts with file from plasma-discover-libs-5.12.4-1.fc28.x86_64
file /usr/share/libdiscover/categories/flatpak-backend-categories.xml from install of plasma-discover-flatpak-5.13.5-1.fc28.x86_64 conflicts with file from plasma-discover-libs-5.12.4-1.fc28.x86_64

I have tried:

yum clean all
dnf clean dbcache
dnf clean expire-cache
dnf clean metadata
dnf clean packages
dnf clean all

It also fails to run any rpm package installs through Discovery - every time I open discover it also says "Please make sure that appstream is properly setup on your system.

Any help would be greatly appreciated!!!!

edit retag flag offensive close merge delete

Comments

I hope this will help you: Have you tried to update your system via dnfdragora or via KDE software updates in the taskbar? Are the results the same or is it working fine?. Are the settings in "Discover" correct? Have you tried to disable flatpak in "Discover" settings temporarily and to try the update again?

heliosstyx gravatar imageheliosstyx ( 2018-10-17 12:57:58 -0500 )edit

I have tried with the KDE software update tool in the taskbar. That gives me the same error message as posted before. I am not familiar with dragora, but I understand it is another front end for DNF. I can try that if you think it will help. It might help to mention that in Discover, under settings, it shows Flatpak under the heading "Missing Backend". I have tried to remove and install again under that option, with no difference. Same error appears. Is there another way to disable flatpak, and reinstall it fresh? It seems that I can't update due to a previous backend version being corr

JollyDev gravatar imageJollyDev ( 2018-10-17 13:14:09 -0500 )edit

Try to uninstall via dnfdragora "plasma-discover-flatpak" and now flatpak should be disabled in "Discover". Then you can try to reinstall the right plasma-discover-flatpak version.

heliosstyx gravatar imageheliosstyx ( 2018-10-17 14:31:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-10-17 16:24:52 -0500

JollyDev gravatar image

Thanks for your help, heliosstyx!

Uninstalling via dnfdragora worked for me.

To break it down:

I opened dnfdragora. Did a search for "plasma-discover" Uninstalled all plasma-discover-flatpak files and dependencies. Reinstalled all using the latest versions shown in dnfdragora, making sure to choose x86_64 files.

Discover now launches properly and everything is up to date! Thanks again for your help!

edit flag offensive delete link more

Comments

@JollyDev: That is all what I wanted, that you are happy with Fedora KDE. Good luck for the future.

heliosstyx gravatar imageheliosstyx ( 2018-10-18 03:47:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-17 10:49:16 -0500

Seen: 313 times

Last updated: Oct 18 '18