Ask Your Question
2

Grub2/EFI keep displayed logging options longer

asked 2018-10-17 18:03:20 -0500

bioshark gravatar image

updated 2018-10-18 13:02:18 -0500

Hi,

I am using dual boot (Fedora 28 and Win 7). When I want to boot into Fedora, I choose the partition to boot from (F11 on power-up) and then the kernels are displayed in grub's list for a split second. This means that the first (latest) option is always chosen. Sometimes I want to boot to an older kernel, but the options disappear too quickly. A use case for this is when my NVIDIA drivers are crashing after a new kernel has been applied.

So, I need to go to the old kernel, run:

sudo systemctl set-default multi-user.target
.. reboot into the latest kernel version, install the latest Nvidia drivers
sudo systemctl set-default graphical.target
reboot

After this all is good. However, due to the quickness of grub I need to reboot a few times so that I can press the down key once so that I choose the previous kernel version.

So, if there is a quick option to increase the time the list is displayed it would be great.

Thank you.

P.S. Many years ago, in Ubuntu, I did play around with Grub and it's options... but it just seems like it was ages ago :)


Edit: I've tried the method suggested by fcomida, but it still goes through the options instantly. I've change the value of GRUB_TIMEOUT from 5 to 5000. This value is updated in /etc/grub2-efi.cfg:

terminal_output console
if [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=5000
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=5000
fi

but still, the behaviour is the same.

P.P.S. I already have dkms installed, and my Nvidia drivers get compiled automatically after every kernel update. Unfortunately sometimes the recompilation fails, and this means that I need a newer version of the driver for this particular kernel. The crash doesn't happen every time the kernel is updated. Just from time to time :) Every second, or third kernel update :)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2018-10-18 14:52:45 -0500

bioshark gravatar image

I found the problem.

I've reversed the boot order of my partitions, and now Fedora is first in the boot order. This means I don't have to press F11 to choose the boot partition, I'll log into Fedora by default. This brings me to the Grub2 kernel choice screen and I have plenty of time to make my choices.

It means that when I was pressing F11 to choose the partition, confirming the choice pressing ENTER passed this keystroke to Grub, and automatically the first choice was made :)

edit flag offensive delete link more
1

answered 2018-10-18 02:33:53 -0500

fcomida gravatar image

Edit /etc/default/grub and change GRUB_TIMEOUT. Then run grub2-mkconfig -o /etc/grub2-efi.cfg I'd also suggest installing dkms for auto recompiling NVidia driver after a kernel update.

edit flag offensive delete link more

Comments

Thank you for your answer. Unfortunately it didn't work. I've updated my question.

bioshark gravatar imagebioshark ( 2018-10-18 13:02:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-17 18:03:20 -0500

Seen: 57 times

Last updated: Oct 18 '18