Ask Your Question
1

[Solved] Cannot start wayland from gdm

asked 2018-10-19 15:22:35 -0500

johanh gravatar image

updated 2018-10-24 14:38:02 -0500

In previous versions of Fedora I've been using gnome-xorg for the desktop session. So in e.g. Fedora 27 I've selected to login from gdm with an xorg session. I've upgraded to Fedora 28, but can't remember what I did to still continue running xorg. After using Fedora 28 for a while I wanted to try wayland again. But now there is no option in gdm to select wayland (I know it is supposed to be default). And even though I set WaylandEnable=true in /etc/gdm/custom.conf, it doesn't start wayland. The only way to start wayland is to open another console and run "dbus-run-session -- gnome-shell --display-server --wayland". This works. I also have nvidia drivers from negativo17 installed and use nvidia-drm.modeset=1 in kernel command line.

Somehow gdm isn't even trying to launch a wayland session when logging in. Is there a way to force it somehow?

I also upgraded the system to Fedora 29, but the problem is still the same.

There are no errors in the journal and only gdm-x-session entries about starting xorg. Nothing about wayland.

edit retag flag offensive close merge delete

Comments

With gdm debugging on I get:

gdm[1220]: GdmLocalDisplayFactory: enumerating seats from logind

gdm[1220]: GdmLocalDisplayFactory: creating seat proxy for seat 'seat0' with path '/org/freedesktop/login1/seat/seat0'

gdm[1220]: GdmLocalDisplayFactory: X11 login display for seat seat0 requested

gdm[1220]: GdmLocalDisplayFactory: Adding display on seat seat0

So it is requesting an X11 login?

and later:

gdm-launch-environment][1241]: GdmSessionWorker: Set PAM environment variable: 'XDG_SESSION_TYPE=x11'
johanh gravatar imagejohanh ( 2018-10-20 04:25:43 -0500 )edit

It doesn't seem to have any impact if leaving or keeping "nvidia-drm.modeset=1" on the kernel command line.

johanh gravatar imagejohanh ( 2018-10-20 04:56:04 -0500 )edit
hhlp gravatar imagehhlp ( 2018-10-20 06:24:42 -0500 )edit

I've been looking at those. I can start wayland separately, but I would like to be able to launch a wayland session from gdm. Now this doesn't happen, it always defaults to xorg without even trying. I'm suspecting that the gdm session on this PC somehow is configured to always run xorg. Maybe reinstalling gdm? Or is there some session/configuration files for gdm?

johanh gravatar imagejohanh ( 2018-10-20 09:11:49 -0500 )edit

Before starting a gnome-shell session, gdm also says:

gdm[1611]: GdmSession: checking if file 'gnome.desktop' is wayland session: no

johanh gravatar imagejohanh ( 2018-10-20 09:13:08 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2018-10-24 08:49:59 -0500

johanh gravatar image

I think I found the reason:

https://gitlab.gnome.org/GNOME/gdm/me...

edit flag offensive delete link more

Comments

I can confirm that this was the reason that gdm never tried to start wayland. When editing /usr/lib/udev/rules.d/61-gdm.rules and commenting the nvidia rule, wayland will be used.

echo $XDG_SESSION_TYPE
wayland
johanh gravatar imagejohanh ( 2018-10-24 14:36:31 -0500 )edit
1

answered 2018-10-21 02:49:30 -0500

rudrab gravatar image

hi, I am not sure if I have understood your problem correctly, but, in the login screen, there is a gear symbol just below the passwd field. you can choose your session from there, right?

edit flag offensive delete link more

Comments

1

Yes, but beginning from Fedora 28 (I think), wayland is default and you cannot choose anything else but Gnome and Gnome Classic. It will fall back to xorg if wayland doesn't work. My problem is that it doesn't even try to launch wayland (according to logs).

johanh gravatar imagejohanh ( 2018-10-21 05:46:45 -0500 )edit
1

But now I've broken gdm totally. I did "dnf reinstall gdm gnome-classic-session gnome-session-wayland-session gnome-session-xsession gnome-shell gnome-session" and now gnome-shell crashes every time I try to login from gdm. Now I have to boot to init 3 and do a "startx" to get any desktop session at all. I guess a reinstall of Fedora begins to sound like a better option. It is a pity. For a long time I've been able to upgrade my systems. I think from Fedora version 1 I've been updating with yum/dnf all the way until now and I've only had to reinstall from scratch a few times.

johanh gravatar imagejohanh ( 2018-10-21 05:53:48 -0500 )edit
1

Gnome-session from gdm works again by removing "rhgb" from kernel command line! That is interesting to say at least. Still no wayland, but X works again when logging in from gdm.

johanh gravatar imagejohanh ( 2018-10-23 12:15:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-10-19 15:22:35 -0500

Seen: 1,644 times

Last updated: Oct 24 '18