Grub menu not visible highdpi ??

asked 2018-11-01 06:51:02 -0500

boyd gravatar image

I have been using F29 since rawhide and I have not been able to see my grub menu. OK: I know this may be confusing but it seems to NOT be related to the new grub feature where the menu does not display by default on new installs where Fedora is the only os on the disk. I get a flashing cursor in the left corner of my display, and I can then blindly press the down arrow key and Enter to select different grub entries. So I know the menu is there! And just to be clear I cannot press F8 or Enter on boot to display a grub menu. I cannot do something like sudo grub2-editenv - set menu_show_once=1 to show the menu. This seems to be a display thing.

I haven't been to concerned about this as I can go into my Bios EFI menu and also select a different os when I need it. But I want my grub menu back. In my research of the issue I came across information about BLS coming in F30.

https://fedoraproject.org/wiki/Change...

I have switched back and forth between BLS and regular grub menu generation, twice and both ways leave me with a black screen. I believe this is related to some grub2 update and my hidpi 1800x3200 display. I have tried various alternatives for GRUB_GFX variable with no success.

Previously on F28 I had issues with too small fonts but there were solutions. But now the issue is no display whatsoever. I am suspecting either a bug or lack of documentation on configuring grub2 with highdpi screens.

So currently I am using BLS. My grub environment is: 

 root  ~  grub2-editenv list
 saved_entry=0 boot_success=1
 boot_indeterminate=0
 kernelopts=root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root  rhgb quiet audit=0

My /etc/default/grub:

 root  ~  cat /etc/default/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root  rhgb quiet audit=0"
GRUB_DISABLE_RECOVERY="false"
#GRUB_GFXMODE=1024x768
GRUB_DISABLE_SUBMENU=false
GRUB_ENABLE_BLSCFG=true

What could be the solution?

edit retag flag offensive close merge delete