Ask Your Question
0

How to enable dbus-org.freedesktop.resolve1.service on Fedora 29

asked 2018-11-05 15:43:42 -0500

janvlug gravatar image

I'm trying to setup a VPN with OpenConnect. This works fine in Fedora 28, but on Fedora 29 I get this error message:

Failed to set DNS configuration: Unit dbus-org.freedesktop.resolve1.service not found.

When I do

systemctl list-unit-files | grep resol

on Fedora 28, I get:

dbus-org.freedesktop.resolve1.service       enabled        
systemd-resolved.service                    enabled      

on Fedora 29, I just get:

systemd-resolved.service                    enabled

How do I enable dbus-org.freedesktop.resolve1 on Fedora 29?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-11-05 17:11:37 -0500

villykruse gravatar image

Try

sudo dnf reinstall systemd

You should have the following files and symbolic links on your system.

/etc/systemd/system/dbus-org.freedesktop.resolve1.service
/etc/systemd/resolved.conf                                          
/usr/lib/systemd/system/systemd-resolved.service

I assume you alread fixed the SELinux issues for systemd-resolved in Fedora28.

edit flag offensive delete link more

Comments

sudo dnf reinstall systemd
created the missing
/etc/systemd/system/dbus-org.freedesktop.resolve1.service
link on Fedora 29.

I do not really understand the remark about SELinux. Was SELinux preventing the creation of this link previously? Does this mean that all Fedora 29 installations are missing this link until systemd is manually reinstalled?

janvlug gravatar imagejanvlug ( 2018-11-06 01:59:44 -0500 )edit

SELinux used to prevent daemons to talk to systemd-resolved via the dbus.

villykruse gravatar imagevillykruse ( 2018-11-06 05:47:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-05 15:43:42 -0500

Seen: 1,202 times

Last updated: Nov 05 '18