Ask Your Question
2

why is docker repo being ignored for fedora 29

asked 2018-11-06 20:44:13 -0500

jimfrenette gravatar image

I want to utilize Built-in Docker support touted on your Workstation page however, I get this message when trying to install it: Failed to synchronize cache for repo 'docker-ce-stable', ignoring this repo.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-11-06 21:30:13 -0500

aeperezt gravatar image

Docker repo files search for urls depending on the Fedora release in case of 29 there are no stable release from Docker yeat, the only version you could use is Docker nightly. You may edit your docker.repo file and hardcode the stable url to 28 and see if that will work. Have not try it my self, so not sure it may work for you.

edit flag offensive delete link more

Comments

1

You can also wait until Docker release 29 support.

aeperezt gravatar imageaeperezt ( 2018-11-06 21:31:03 -0500 )edit
1

The issue of Fedora 29 support is also in the Docker project's issue tracker: https://github.com/docker/for-linux/i...

lkiesow gravatar imagelkiesow ( 2018-11-10 16:34:03 -0500 )edit

nightly does not work, docker-ce requires containerd.io to be installed

jimfrenette gravatar imagejimfrenette ( 2018-11-17 17:09:00 -0500 )edit

I found hardcoding 28 into the stable url (replace $releasever by 28 in /etc/yum.repos.d/docker-ce.repo (mainly based on this tutorial )) to be working for me until docker manages to release the stable version in their fedora 29 branch.

red gravatar imagered ( 2019-01-09 08:33:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-06 20:44:13 -0500

Seen: 2,185 times

Last updated: Nov 06 '18