Ask Your Question
0

twofold: gdm ignoring .desktop file and how to disable pulseaudio for a user?

asked 2018-11-08 22:56:15 -0500

antigenx gravatar image

I copied and modified a file in /usr/share/xsessions and gdm doesn't appear to be picking up the new file on the login screen.

src: /usr/share/xsessions/kodi.desktop
content:
[Desktop Entry]
Name=Kodi
Comment=This session will start Kodi media center
Exec=kodi-standalone
TryExec=kodi-standalone
Type=Application

new: /usr/share/xsessions/kodi2.desktop
content: 
[Desktop Entry]
Name=Kodi-ALSA 
Comment=This session will start Kodi media center
Exec=pasuspender -- env AE_SINK=ALSA kodi-standalone 
TryExec=pasuspender --env AE_SINK=ALSA kodi-standalone
Type=Application

maybe it doesn't like what I've done? what i'm basically trying to do is disable pulseaudio but for whatever reason when i put "autospawn = no" in ~/.config/pulse/client.conf file, fedora ignores it and launces pulseaudio anyway.

edit retag flag offensive close merge delete

Comments

Ok. so I've learned that .desktop files definitely do not accept complex entries in Exec, even if you surround them with quotes.

Still have not figured out how to disable Pulseaudio for a given user. Seems you can disable it one-time with systemctl --user stop pulseaudio.service && systemctl --user stop pulseaudio.socket but using "disable" will not permanently disable it like one would hope/expect. So, with the fact that it ignores client.conf's autospawn=no entry.. I do not see anyway forward with this. :(

antigenx gravatar imageantigenx ( 2018-11-10 10:12:58 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-11-11 10:40:53 -0500

antigenx gravatar image

OK, I've figured out how to disable pulseaudio for an individual user.

Login to user account.
mkdir -p $HOME/.config/systemd/user
systemctl --user mask pulseaudio.socket
systemctl --user mask pulseaudio.service
Restart your computer.

What that's doing (or should do) is symlink $HOME/.config/systemd/user/pulseaudio.* to /dev/null which overrides the existing system-wide systemd link in /etc/systemd/user/pulseaudio.*

If the systemctl command doesn't work, you can use ln -s /dev/null $HOME/.config/systemd/user/pulseaudio.{extension}

To undo: systemctl --user unmask pulseaudio.{extension} or rm $HOME/.config/systemd/user/pulseaudio.*

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-11-08 22:56:15 -0500

Seen: 59 times

Last updated: Nov 11 '18