Ask Your Question
0

Bumblebee doesn't work after update to Fedora29

asked 2018-11-09 18:09:59 -0500

jpill gravatar image

updated 2018-11-09 18:23:15 -0500

I updated to Fedora 29 around two weeks ago, i had problems with the graphic server (xorg and Wayland)wayland).

Now wayland is working but Bumblebee doesn't work with the nvidia graphic card. I followed the instructions from the wiki wiki but it doesn't work for me no.

When i try optirun i get an error:

 optirun glxgears 
[ 5524.361213] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 5524.361256] [ERROR]Aborting because fallback start is disabled.

I uninstalled bumblebee and installed again but the result is the same. Also hoped for a kernel update, witch just happened, but i got the same.

I have Wayland and Xorg, is an ASUS with nvidia geforce 610M I try to start session with Mate but after i type the password and hit enter key it returns to the login screen again.

The kernel now is: 4.18.17-300.fc29.x86_64

How can i fix bumblebee to work with nvidia card?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ¬Ľ oldest newest most voted
0

answered 2018-11-09 19:20:51 -0500

fcomida gravatar image

Check /etc/sysconfig/nvidia/ directory. If there are two files NVIDIA-Linux-x86_64-<VERSION>.run remove the older one (left over by the upgrading process) and reboot.

edit flag offensive delete link more

Comments

In the folder there was two files one the nvidia driver and the other are libs to intel (intel-libs.tar.gz), so i deleted the driver. I rebooted and the result was the same, so i followed the instructions from the wiki and rebooted, the same thing.

jpill gravatar imagejpill ( 2018-11-09 20:31:46 -0500 )edit

No no you must have only one driver in that directory. It happened to me after upgrading to f29 and rebuilding the driver failed (because of the presence of two NVIDIA-Linux-XXXX.run files). I have a 810m card and it's now working well. Please reinstall bumblebee and run: sudo bumblebee-nvidia --force and post all compiling errors. My driver is NVIDIA-Linux-x86_64-390.87.run

fcomida gravatar imagefcomida ( 2018-11-10 10:03:04 -0500 )edit

Sometimes I've had to boot to single (or nomodeset 3) and from there run "sudo bumblebee-nvidia --force".

johanh gravatar imagejohanh ( 2018-11-10 12:07:06 -0500 )edit

In single mode i run: bumblebee-nvidia --force and the install fails. The last lines of nvidia-installer.log says:

/sbin/ldconfig: libraries libGL.so.1 and libGL.so.1.7.0 in directory /lib have same soname but different type.
   executing: '/sbin/depmod -a '...
-> done.
-> Driver file installation is complete.
ERROR: Unable to load the 'nvidia-drm' kernel module.
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.
jpill gravatar imagejpill ( 2018-11-10 20:27:05 -0500 )edit

Your system is messed up. You have a 64 bits library in /lib that should belong to /lib64. No idea why it ended up this way. Have you manually installed anything? Use rpm -qf <path-to-file> for finding out which files in /lib do not belong to any rpm and remove them.

fcomida gravatar imagefcomida ( 2018-11-11 03:42:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-09 18:09:59 -0500

Seen: 533 times

Last updated: Nov 09 '18