Ask Your Question
0

Upgrade to 29 from 28 sound not working

asked 2018-11-11 02:49:36 -0600

Tomer gravatar image

updated 2018-11-11 03:19:00 -0600

hhlp gravatar image

I just upgrade fedora to 29 and the sound is disable from the menu no input/output interfaces display, attached is output of pulseaudio -vvv

> Blockquote
> D: [pulseaudio] module-systemd-login.c: Added new session 2
I: [pulseaudio] core.c: exit_idle_time: 20 -> 0
I: [pulseaudio] module.c: Loaded "module-systemd-login" (index: #18; argument: "").
I: [pulseaudio] module.c: Loaded "module-position-event-sounds" (index: #19; argument: "").
D: [pulseaudio] stream-interaction.c: Using role 'phone' as trigger role.
D: [pulseaudio] stream-interaction.c: Using roles 'music' and 'video' as cork roles.
I: [pulseaudio] module.c: Loaded "module-role-cork" (index: #20; argument: "").
I: [pulseaudio] module.c: Loaded "module-filter-heuristics" (index: #21; argument: "").
I: [pulseaudio] module.c: Loaded "module-filter-apply" (index: #22; argument: "").
W: [pulseaudio] module-ladspa-sink.c: The 'master' module argument is deprecated and may be removed in the future, please use the 'sink_master' argument instead.
**E: [pulseaudio] module-ladspa-sink.c: Master sink not found.
E: [pulseaudio] module.c: Failed to load module "module-ladspa-sink" (argument: "sink_name=ladspa_output.mbeq_1197.mbeq master=alsa_output.usb-Generic_USB_Audio_200901010001-00.analog-stereo-headphone plugin=mbeq_1197 label=mbeq control=-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-21.0,-21.0,-27.0"): initialization failed.
E: [pulseaudio] main.c: Sink ladspa_output.mbeq_1197.mbeq does not exist.
E: [pulseaudio] main.c: No sink found by this name or index.
E: [pulseaudio] main.c: Failed to initialize daemon.
I: [pulseaudio] module.c: Unloading "module-filter-apply" (index: #22).**
I: [pulseaudio] module.c: Unloaded "module-filter-apply" (index: #22).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-filter-heuristics" (index: #21).
I: [pulseaudio] module.c: Unloaded "module-filter-heuristics" (index: #21).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-role-cork" (index: #20).
I: [pulseaudio] module.c: Unloaded "module-role-cork" (index: #20).

> Blockquote

when i try to run this command alsamixer ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

cannot open mixer: Connection refused

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2018-11-15 03:06:15 -0600

Tomer gravatar image

Thanks a lot ,

I manage to solve the issue by comment out some old configuraion related to Equalized

which was config in ~/.pulse/default.pa file

BEGIN: Equalized audio configuration

load-module module-ladspa-sink sink_name=ladspa_output.mbeq_1197.mbeq

master=alsa_output.usb-Generic_USB_Audio_200901010001-00.analog-stereo-headphone

plugin=mbeq_1197 #label=mbeq control=-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-0.2,-21.0,-21.0,-27.0

set-default-sink ladspa_output.mbeq_1197.mbeq

set-sink-volume alsa_output.usb-Generic_USB_Audio_200901010001-00.analog-stereo-headphone

65536

set-sink-mute alsa_output.usb-Generic_USB_Audio_200901010001-00.analog-stereo-headphone

0

END: Equalized audio configuration

edit flag offensive delete link more
0

answered 2018-11-11 17:16:43 -0600

hellork gravatar image

updated 2018-11-11 17:30:38 -0600

Also check with echo $PULSE_SERVER to see if it points to a non-existent network PulseAudio server. That is a hidden cause of cryptic "connection refused" errors. Remove the setting from configuration files if you want to use the regular default PulseAudio server.

Gamers sometimes configure PULSE_SERVER=$PHONE_IP in the user's .bashrc to route their desktop PC's audio over WiFi to Termux app on their Android phone. This lets them use their phone's headphone jack as a sort of wireless headset. Various flavors of Android Linux also use PULSE_SERVER=127.0.0.1:4712, for example, to send sound to XserverXSDL app on the same phone when they don't feel like configuring PulseAudio. When PULSE_SERVER is set, clients don't even need PulseAudio installed. With ALSA by default configured to route sound through PulseAudio (pcm.!default {type pulse} in /etc/alsa/conf.d/99-pulseaudio-default.conf) ALSA audio is forwarded over the network to a working PulseAudio server.

edit flag offensive delete link more
0

answered 2018-11-11 08:31:08 -0600

ed209 gravatar image

Quite probably you have some old ~/.pulse/ settings. Rename the directory (do not erase it!), logoff, logon and try again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-11 02:46:39 -0600

Seen: 147 times

Last updated: Nov 11