fedora 29 error in 32 bit -i386 Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=updates-released-f29&arch=i386 [Could not resolve host: mirrors.fedoraproject.org]

asked 2018-11-11 14:09:17 -0500

Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/met... [Could not resolve host: mirrors.fedoraproject.org]

edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora. Checking, This Site is able to reach it, and I can ping it. I'd suggest emailing the project's technical contact, but there's none listed. Try running nslookup mirrors.fedoraproject.org in a terminal to see if it really resolves. I get 36 different answers, some of them in IPV6.

sideburns gravatar imagesideburns ( 2018-11-11 14:28:48 -0500 )edit

verify that you have Internet.

aeperezt gravatar imageaeperezt ( 2018-11-11 15:15:42 -0500 )edit

disable ipv6 on your modem or ISP. If ipv6 is enabled dnf runs commands with ipv6 the first time, then ipv4. If you can not disable ipv6 on your modem(ISP) , use the -4 option , always in your commands to force dnf use ipv4 instead of ipv6 e.g.

sudo dnf install gimp -4

Another example

sudo dnf update -4
christianbueno gravatar imagechristianbueno ( 2018-11-11 20:43:25 -0500 )edit