Ask Your Question
0

Why was "resume=" added to my grub line?

asked 2018-11-12 14:51:06 -0500

kawedel gravatar image

A few days ago my F28 system started slowing to a crawl after 20 minutes or so of operation. Then I finally discovered the problem: "resume=" followed by the UUID of my swap partition had been added to the grub line, and it was causing the machine to use swap more way than usual. I took it out and now everything runs well, but I'm wondering how it got there. Can I prevent this from happening again? Would that cause other problems?

edit retag flag offensive close merge delete

Comments

1

I am pretty sure that "resume=" entry was always there since the original installation of the system.

villykruse gravatar imagevillykruse ( 2018-11-13 01:41:18 -0500 )edit

vm.swapinessis what defines "how quick" your system starts to swap: https://duckduckgo.com/?q=vm.swapiness

florian gravatar imageflorian ( 2018-11-13 13:44:32 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2018-11-12 19:08:08 -0500

sixpack13 gravatar image

updated 2018-11-14 13:50:18 -0500

you need it to hibernate your box !

And if you just removed that entry and did anything else afterwards it has absolutely ZERO influence how your box runs, especially regarding more or less swap usage. And - I guest - it will be overwritten during next grub update.

Important:

the UUID for swap (output from command "sudo blkid") needs to be the same in /etc/default/grub and in /etc/fstab.

Why ?

simply put: to tell the box where to hibernate and to generate correct boot files

during kernel installation the UUID becomes important:

from /etc/default/grub to generate the correct boot parameter and from /etc/fstab to tell dracut what the correct swap partition is and what becomes a entry in an correct bootable initramfs-xyz.img

a wrong UUID for swap in initramfs causes boot problems. it just tries to mount a wrong swap partition, ever and ever again

if you adjust /etc/default/grub you need to do one of the following:

for EFI:          sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

for Legacy Bios:  sudo grub2-mkconfig -o /boot/grub2/grub.cfg

which one you need reveals:

[ -d /sys/firmware/efi/efivars ] && echo EFI || echo Legacy Bios

P.S.

check with "sudo swapon -s" if the partitions for swap (/dev/sd...) is same as blkid tells !

if you need to generate an new initramfs:

sudo dracut -f /boot/initramfs-$(uname -r).img $(uname -r)

check what's real up with your box (dmesg, journalctl) !!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-11-12 14:51:06 -0500

Seen: 245 times

Last updated: Nov 14 '18