Ask Your Question
1

F29 Freezes on Boot

asked 2018-11-15 09:13:05 -0600

Garred gravatar image

I bought a new laptop, Intel i7-8th, Nvidia GTX 1060, SSD 256 GB, and 1TB HD. I installed windows first, then installed fedora 28. I had some trouble thanks to the Nvidia Optimus technology but solved it with Bumblebee. I decided to upgrade to fedora 29. It downloaded and successfully installed. Sadly it freezes upon boot. It only loads up to the fedora logo, and then gets stuck there. If I press any keys to look for errors, everything completes, with no fails. After everything, a simple underscore stays in the top-left corner.

I tried everything, and I cannot even use the keyboard. Ctrl + Alt + F2 doesn't work. No keys perform any action whatsoever.

I have no idea what to do since it would seem I should give up on Fedora 29 for the time being.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2019-02-02 13:56:46 -0600

Fabash gravatar image

Hello

What you see here is that you still have the previous kernel (s)build on F28. But you have upgraded your laptop to F29 and so, you see also now the new kernels. (if/when you upgrade packages without excluding the kernel, the old ones will be removed)

By default, GRUB2 proposes the latest installed kernel selected by default. There is a way to select another default option and keep it like this. You could have a look at options GRUB_DEFAULT, and GRUB_SAVEDEFAULT here: https://www.gnu.org/software/grub/man...

You would need first to edit /boot/grub2/grub.cfg (as root/sudo) and re-generate /boot/grub2/grub.cfg using: $ sudo grub2-mkconfig -o /boot/grub2/grub.cfg It is discouraged to edit this file directly as it will be overwritten at next kernel updated.

But you need to be careful as you could get into some trouble to boot correctly if yo make some mistakes. Hope this helps !

edit flag offensive delete link more

Comments

@Garred: "I have no idea what to do since it would seem I should give up on Fedora 29 for the time being" Be careful as if you update kernel, you might loose your working F28 kernel, and it will be more difficult for you to access your desktop if you have not solved your problem.

Fabash gravatar imageFabash ( 2019-02-02 14:04:56 -0600 )edit
1

answered 2018-11-15 15:47:22 -0600

rzbyn gravatar image

Try to press E on boot (boot menu?) then then find and delete rhgb quiet or press esc while fedora logo is loading.

edit flag offensive delete link more

Comments

I tried to have a look at it, and I finally got into emergency mode, turned off rhgb and quiet, but I find nothing. The journal doesn't tell me much either. Luckily, after the update, my Fedora 28 boot option works, and it takes me to Fedora 29. I find that strange, but it works

Thanks for helping me

Garred gravatar imageGarred ( 2018-11-16 07:43:51 -0600 )edit

I do, however, want to ask, if there is a way to change the grub boot order. I want to boot from the second boot option, i.e. Fedora 28, instead of Fedora 29. I tried going to /boot/efi/EFI/fedora/grub.cfg, but there was no such file. I went to /boot/grub2/grub.cfg, and change as necessary, yet when I executed the necessary command, I still would end up booting into Fedora 29, which then directly leads me to the emergency boot option.

Garred gravatar imageGarred ( 2018-11-16 08:26:47 -0600 )edit
0

answered 2019-02-02 13:13:49 -0600

Orriginal gravatar image

I have this same problem....did you ever find the Fix ?

edit flag offensive delete link more

Comments

Sorry if you already have done it, but could I suggest that you have a look at the boot's log, using: $ sudo journalctl -b >BOOT ID> The BOOT ID is the first number that you can find on the lines outputs using: $ sudo journalctl --list-boots

Fabash gravatar imageFabash ( 2019-02-02 14:02:40 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-11-15 09:13:05 -0600

Seen: 472 times

Last updated: Feb 02