Ask Your Question
0

OpenOffice don't work in KDE 29!

asked 2018-11-15 12:22:52 -0500

rigbyk3 gravatar image

updated 2018-11-16 11:13:49 -0500

Hi,Java has been installed before with dnf install java, download and install Apache OpenOffice in Fedora KDE 29 with instructions in: https://www.openoffice.org/download/c....

When click the icon Writer show "the start" but never opens, when run openoffice4 in terminal shows this:

/opt/openoffice4/program/soffice: line 121:  2723 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"

How can solve?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-11-16 12:57:16 -0500

rigbyk3 gravatar image

Hey guys, solution founded!!!

Just superuser run dnf install */libgdk_pixbuf_xlib-2.0.so.0

from: https://forum.openoffice.org/en/forum...

edit flag offensive delete link more
1

answered 2018-11-15 16:28:21 -0500

ozeszty gravatar image

updated 2018-11-16 13:34:59 -0500

Hi,

do you need explicitly OpenOffice? LibreOffice is the successor to OpenOffice, you can install it by running:

dnf install libreoffice-calc libreoffice-writer libreoffice-impress libreoffice-math libreoffice-draw libreoffice-emailmerge  libreoffice-opensymbol-fonts libreoffice-help-$(echo $LANG | cut -d_ -f1) libreoffice-langpack-$(echo $LANG | cut -d_ -f1) autocorr-$(echo $LANG | cut -d_ -f1)

To use LibreOffice Math run libreoffice --math in terminal, or...

From what I see LibreOffice Math desktop entry is hidden by default. Copy it from /usr/share/applications/libreoffice-math.desktop to ~/.local/share/applications/ and comment out NoDisplay=true line (prepend it with #). It should again be available, and thanks to copying it to user directory, it won't be overwritten by updates.

edit flag offensive delete link more

Comments

yes, or the complete libreOffice suite

sudo dnf install libreoffcie*
christianbueno gravatar imagechristianbueno ( 2018-11-15 17:13:50 -0500 )edit

Or by "Gnome Software" App

christianbueno gravatar imagechristianbueno ( 2018-11-15 17:16:19 -0500 )edit

Well...

I work with MathML, Openoffice includes "Math" that is really useful for me, in Fedora 28 I install LibreOffice with dnf and don't include "Math" only can use inside "Writer".

In Fedora 27 and 28 works but in 29 not, why?

rigbyk3 gravatar imagerigbyk3 ( 2018-11-16 11:28:25 -0500 )edit

It seems that Math's desktop entry was set to be hidden, I updated my answer with instructions on how to deal with it.

ozeszty gravatar imageozeszty ( 2018-11-16 13:41:04 -0500 )edit
0

answered 2018-11-15 12:32:23 -0500

heliosstyx gravatar image

Please try this one: https://tecadmin.net/install-apache-o...

I hope it will help you.

edit flag offensive delete link more

Comments

Hi heliosstyx, basically is the same method described in openoffice.org.

rigbyk3 gravatar imagerigbyk3 ( 2018-11-16 11:22:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-15 12:22:52 -0500

Seen: 261 times

Last updated: Nov 16 '18