Ask Your Question
1

system-config-user wayland

asked 2018-11-21 18:21:28 -0600

nmgiffin gravatar image

updated 2018-11-21 21:51:32 -0600

aeperezt gravatar image

I believe there is a problem using system-config-users on fedora 28 with the gnome desktop under wayland. I call up the users&groups app which I believe directs to system-config-users and it fails to open properly. I get the authentication window and enter a correct password but then no GUI opens up. If I am using the old gnome-Xorg desktop it opens correctly.

edit retag flag offensive close merge delete

Comments

You Gnome you have the Settings functions, which can perform the same function.

villykruse gravatar imagevillykruse ( 2018-11-22 06:02:13 -0600 )edit

Not really. You cannot, for instance, change or add groups to users.

ed209 gravatar imageed209 ( 2018-11-22 08:26:46 -0600 )edit

Yes. Sorry! Wayland of course. Changing the access control as specified in the answer does work and I suppose this is a new feature for improved security, but was there some documentation or update notes published that I missed, that explained this new requirement? Are there other differences between running Gnome with Wayland and Gnome Classic or Gnome-Xorg that I should know? I've been putting off running under Wayland due to other graphic problems, but as those seemed to have been resolved in Fedora 28 I would like to start using it more, so perhaps you could point me to a concise document.

nmgiffin gravatar imagenmgiffin ( 2018-11-22 14:19:46 -0600 )edit

Well, actually this documentation is rather well hidden, and it's old stuff as it's several releases that fedora uses wayland either in gdm or as default display server. Useful informations could be found here:

https://fedoraproject.org/wiki/How_to...

ed209 gravatar imageed209 ( 2018-11-22 17:19:19 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-11-21 18:49:15 -0600

ed209 gravatar image

It is called Wayland, NOT weyland. It's because you want to run a graphical program as root in Wayland. In order to do that you need permissions and have to write first:

xhost si:localuser:root

and when you're done with the program

xhost -si:localuser:root

in order to remove permissions afterwards.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-21 18:21:28 -0600

Seen: 47 times

Last updated: Nov 21