Ask Your Question
1

Unable to set native resolution on nvidia HDMI output

asked 2018-11-24 06:08:26 -0600

emkey gravatar image

Hi everyone,

I am using a Dell U2515h with a native resolution of 2560x1440@60. On my Thinkpad connected via DisplayPort everything works fine out of the box.

On my Desktop, however, I didn't manage to set the resolution by any means. The Desktop computer is connected via HDMI on the following graphics card.

lspci | grep -i nvidia
<br> 01:00.0 VGA compatible controller: NVIDIA Corporation GF110 [GeForce GTX 560 Ti 448 Cores] (rev a1)

I know there is some issue with the combination of the graphics card, hdmi connection and the monitor. Somehow the edid information can not be read properly. On windows I was able to just set a custom resolution and everything worked fine.

On fedora, i haven't yet managed to resolve the issue. I found a lot of guides, but none worked for me.

The following one is trying to use xrandr to use a ModeLine Entry:
https://medium.com/@radu.balaban/2560...

This gives me the following error:

[root@linux ~]# xrandr --addmode HDMI-0 "2560x1440R"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  139 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  31
  Current serial number in output stream:  32

I have also already exported EDID information on the Thinkpad and tried to use it on the Desktop, but still no success.

Any ideas what else to try to solve this issue?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2018-11-25 05:21:46 -0600

emkey gravatar image

updated 2018-11-25 06:43:36 -0600

I think I might have found the problem. Looking at journalctl there is the following message:

Nov 25 11:59:14 linux.fritz.box /usr/libexec/gdm-x-session[1709]: (--) NVIDIA(GPU-0): DELL U2515H (DFP-1): connected
Nov 25 11:59:14 linux.fritz.box /usr/libexec/gdm-x-session[1709]: (--) NVIDIA(GPU-0): DELL U2515H (DFP-1): Internal TMDS
Nov 25 11:59:14 linux.fritz.box /usr/libexec/gdm-x-session[1709]: (--) NVIDIA(GPU-0): DELL U2515H (DFP-1): 225.0 MHz maximum pixel clock

The edid information (read on the Thinkpad) has the following:

Detailed mode: Clock 241.500 MHz, 553 mm x 311 mm
               2560 2608 2640 2720 hborder 0
               1440 1443 1448 1481 vborder 0
               +hsync -vsync 
               VertFreq: 59 Hz, HorFreq: 88786 Hz

The pixel clock required for the resolution seems to be higher than the limit the driver recognizes. Now is there any way to override this?

EDIT: Debug output says that the pixel clock is the problem as well:

(WW) NVIDIA(GPU-0):   Validating Mode "2560x1440_60":
(WW) NVIDIA(GPU-0):     Mode Source: EDID
(WW) NVIDIA(GPU-0):     2560 x 1440 @ 60 Hz
(WW) NVIDIA(GPU-0):       Pixel Clock      : 241.50 MHz
(WW) NVIDIA(GPU-0):       HRes, HSyncStart : 2560, 2608
(WW) NVIDIA(GPU-0):       HSyncEnd, HTotal : 2640, 2720
(WW) NVIDIA(GPU-0):       VRes, VSyncStart : 1440, 1443
(WW) NVIDIA(GPU-0):       VSyncEnd, VTotal : 1448, 1481
(WW) NVIDIA(GPU-0):       Sync Polarity    : +H -V
(WW) NVIDIA(GPU-0):     Mode is rejected: PixelClock (241.5 MHz) too high for
(WW) NVIDIA(GPU-0):     Display Device (Max: 225.0 MHz).
(WW) NVIDIA(GPU-0):     Mode "2560x1440_60" is invalid.
edit flag offensive delete link more

Comments

I got it to use the mode with the following options:

Modeline "2560x1440R"  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync
Option         "metamodes" "2560x1440R"
Option "ModeValidation" "NoMaxPClkCheck"

Log also says mode is being used:

(II) NVIDIA(0): Setting mode "2560x1440R"

Unfortunately all I get is a blank screen.

emkey gravatar imageemkey ( 2018-11-25 07:03:29 -0600 )edit
0

answered 2018-11-25 08:32:55 -0600

emkey gravatar image

For anyone else with the same problem: I found the solution here: https://wiki.archlinux.org/index.php/...

Using nouveau drivers you can change the pixel clock limit with kernel parameter nouveau.hdmimhz. I set mine to 297 and the system booted to 2560x1440.

edit flag offensive delete link more

Comments

I think I have discovered the real reason of the problem. From Dell's site your display has hdmi and dp. The dp is limited to v1.2 only, presumably the hdmi is only v1.4 (not specified). Now, 1.4 allows only 1080p resolutions at 60Hz and something in 3D. Higher resolutions do not reach even 30Hz refresh. It could well be possible that its native resolution is outside the range for that hdmi and should be forced somehow, like you discovered. That also makes clear why DP works instead, v1.2 having higher bandwidth.

ed209 gravatar imageed209 ( 2018-11-25 13:38:23 -0600 )edit

I don't know about the the monitor hdmi version, but even die graphics card only seems to be supporting 1.4.

With the hdmimhz parameter everything works fine on nouveau driver. But unfortunately Photoshop Lightroom does not work without proprietery drivers. Is there any similar option on the proprietary drivers? I wasn't able to find any.

emkey gravatar imageemkey ( 2018-11-26 11:59:35 -0600 )edit
0

answered 2018-11-24 10:37:12 -0600

ed209 gravatar image

First of all, stop following dubious guides written two years ago for a new distribution. Provided you have Fedora 29, you don't write anything about, that won't help. You are sure you're using X11 and not Wayland, aren't you?

Second. What happens when using nvidia driver? Set it up following rpmfusion drivers and instructions therein.

edit flag offensive delete link more

Comments

I just tried whatever I was able to find as nothing seemed to work so far.

Yes, I'm on Fedora 29 and I have nvidia drivers installed. I had them once set up per these directions (https://www.if-not-true-then-false.co...) and right now I have the RPMFusion packages installed.

Since the nvidia drivers were installed I'm on X11.

[root@linux ~]# loginctl show-session 2 -p Type
Type=x11

I'm using nvidia driver version 390.87.

emkey gravatar imageemkey ( 2018-11-25 04:34:05 -0600 )edit

Please see my comment in response to your solution.

ed209 gravatar imageed209 ( 2018-11-26 08:28:38 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-24 06:08:26 -0600

Seen: 29 times

Last updated: Nov 25