Ask Your Question
0

firewalld won't stop when on wifi

asked 2018-11-25 03:18:36 -0600

esbentoke gravatar image

When on a cabled connection, everything works well. When on wifi - not so much. Here's before stopping:

[esben@fedora-desktop ~]$ sudo systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
   Active: active (running) since Sun 2018-11-25 09:47:27 CET; 4s ago
     Docs: man:firewalld(1)
 Main PID: 2945 (firewalld)
    Tasks: 2 (limit: 4915)
   Memory: 28.3M
   CGroup: /system.slice/firewalld.service
           └─2945 /usr/bin/python3 /usr/sbin/firewalld --nofork --nopid

Nov 25 09:47:27 fedora-desktop systemd[1]: Starting firewalld - dynamic firewall daemon...
Nov 25 09:47:27 fedora-desktop systemd[1]: Started firewalld - dynamic firewall daemon.

Everything looks good. Now, stopping it with 'sudo systemctl stop firewalld' (and some three minutes later):

[esben@fedora-desktop ~]$ sudo systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
   Active: failed (Result: timeout) since Sun 2018-11-25 09:58:09 CET; 5min ago
     Docs: man:firewalld(1)
  Process: 2945 ExecStart=/usr/sbin/firewalld --nofork --nopid $FIREWALLD_ARGS (code=killed, signal=KILL)
 Main PID: 2945 (code=killed, signal=KILL)
    Tasks: 1 (limit: 4915)
   Memory: 8.8M
   CGroup: /system.slice/firewalld.service
           └─3315 /sbin/rmmod nf_conntrack

Nov 25 09:55:09 fedora-desktop systemd[1]: Stopping firewalld - dynamic firewall daemon...
Nov 25 09:56:39 fedora-desktop systemd[1]: firewalld.service: State 'stop-sigterm' timed out. Killing.
Nov 25 09:56:39 fedora-desktop systemd[1]: firewalld.service: Killing process 2945 (firewalld) with signal SIGKILL.
Nov 25 09:56:39 fedora-desktop systemd[1]: firewalld.service: Killing process 3076 (gmain) with signal SIGKILL.
Nov 25 09:56:39 fedora-desktop systemd[1]: firewalld.service: Killing process 3315 (rmmod) with signal SIGKILL.
Nov 25 09:56:39 fedora-desktop systemd[1]: firewalld.service: Main process exited, code=killed, status=9/KILL
Nov 25 09:56:39 fedora-desktop systemd[1]: firewalld.service: Killing process 3315 (rmmod) with signal SIGKILL.
Nov 25 09:58:09 fedora-desktop systemd[1]: firewalld.service: Processes still around after final SIGKILL. Entering failed mode.
Nov 25 09:58:09 fedora-desktop systemd[1]: firewalld.service: Failed with result 'timeout'.
Nov 25 09:58:09 fedora-desktop systemd[1]: Stopped firewalld - dynamic firewall daemon.

It times out. And now i am left with an un-killable '/sbin/rmmod nf_conntrack' process that uses 100% on one of the CPU cores, and the whole system becomes sluggish. I nothing in /var/log/firewalld.

I don't really know what to do next. It's a problem because it prevents a clean shutdown - the computer ultimately shuts off with '/' still mounted since it is in use by the un-killable process mentioned above. So right now i have to run without firewall, which is hardly ideal.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-11-25 13:43:56 -0600

ed209 gravatar image

Definitively a problem with your wifi driver. Try an usb wifi that works or just use ethernet.

edit flag offensive delete link more

Comments

That's not very constructive. My WiFi driver works perfectly for every other purpose. Surely there must be something that can be done to remedy this.

esbentoke gravatar imageesbentoke ( 2018-11-26 00:51:59 -0600 )edit

It is. Guessing your hardware, your distribution and everything else is already at the very edge of human possibilities and some more.

ed209 gravatar imageed209 ( 2018-12-01 21:09:37 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-25 03:18:36 -0600

Seen: 30 times

Last updated: Nov 25