Ask Your Question
1

Can't get Netflix working on Fedora 29 (Firefox browser)

asked 2018-11-25 04:02:16 -0600

eeijlar gravatar image

updated 2018-11-26 13:32:01 -0600

I can't get Netflix to work on Fedora 29. I get the following error:

Oops something went wrong...

Netlflix Video Player Unavailable

We're having trouble playing Netflix in your browser. Please make sure you use an Official version of Firefox.

Error Code: F7355

I have searched for that error, and it says to clear browser caches and it also says there is a problem with codecs:

https://help.netflix.com/en/node/1051...

It doesn't say which codec specifically.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2018-11-26 15:05:01 -0600

eeijlar gravatar image

After reading half the internet :) and several hours of trying different things, the following worked for me.

Assuming you have already tried this:

https://itsfoss.com/netflix-firefox-l...

And you have already done this:

dnf groupinstall Multimedia

Netflix will either use HTML 5 or Silverlight to play video. Since we are not on Microsoft, then it has to use HTML 5, so first off you have to check HTML 5 is working:

https://www.youtube.com/html5

This was showing H.264 and MSE & H.264 as not working. This then led me to this answer:

https://ask.fedoraproject.org/en/ques...

which worked...

edit flag offensive delete link more
1

answered 2018-11-25 18:35:46 -0600

davidva gravatar image

Are you using Firefox? well; Firefox will to download widevine plugin and plays finally netflix...

Other option; you can use "chromium-freeworld" available in UnitedRPMs...

dnf -y install chromium-freeworld
edit flag offensive delete link more

Comments

I am using Firefox. I did 'dnf groupupdate Multimedia' which pulled in some things, and I followed this guide to enable widevine in the browser:

https://itsfoss.com/netflix-firefox-l...

I also enabled DRM content in Firefox. It made no difference, same error. It looks like it's not possible with Firefox.

eeijlar gravatar imageeeijlar ( 2018-11-26 13:31:36 -0600 )edit
1

answered 2018-11-25 14:04:21 -0600

ed209 gravatar image

You could either use chrome, or enable drm in firefox preferences and install Widevine and OpenH264 add-ons.

edit flag offensive delete link more
0

answered 2018-11-26 15:55:49 -0600

pam987 gravatar image

Thanks for the information.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-11-25 04:02:16 -0600

Seen: 194 times

Last updated: Nov 26