How to stop laptop from suspending

asked 2018-11-27 14:25:12 -0600

updated 2018-11-27 14:58:00 -0600

Hello,

I have a Toshiba Satellite Pro laptop which had windows vista and Linux mint running on it. Both OS's worked fine, no problems. I then proceeded to install Fedora 29 onto the laptop, using the install wizard to format the HD.

The installation was successful and I was told I could restart the laptop. Once I did this the laptop keeps on going into suspend (or hibernate, I am not sure) mode every 10 to 15 seconds. The fist time it happens is even before the login screen loads! Upon pressing the power button the process continues. I have tried two things:

1) In the terminal (in the GUI) run sudo systemd-inhibit /bin/bash

2) In an alternate window (alt+F2) I have set pretty much everything to "ignore" in the /etc/systemd/logind.conf file.

Neither of these work. The laptop goes into hibernation/suspend mode every 10 to 15 seconds. This is a fresh install.

Any suggestions or ideas of what I could try or what could be wrong would be much appreciated!

Thanks

edit retag flag offensive close merge delete

Comments

Is your laptop running off of the battery or is it plugged in, please?

MettaCrawler gravatar imageMettaCrawler ( 2018-11-28 06:22:18 -0600 )edit

Hi MettaCrawel, the laptop is plugged in. There is no battery installed at all (the battery is lost - I do not have one). That is an interesting question - I am curious where you are going with this :)

v1talogy gravatar imagev1talogy ( 2018-11-28 09:56:23 -0600 )edit

The fact that there is no battery in your laptop might be causing the system to suspend.

MettaCrawler gravatar imageMettaCrawler ( 2018-11-28 10:55:22 -0600 )edit

OK thanks, adding a comment here for reference. Both Fedora 28 and 29 does this. I installed mint and it is running fine, no problems. Very unfortunate as I would have liked to use Fedora :(

Thanks for your input MettaCrawler.

v1talogy gravatar imagev1talogy ( 2018-11-28 23:52:20 -0600 )edit

You could run Fedora in a virtual machine on Mint.

MettaCrawler gravatar imageMettaCrawler ( 2018-11-29 08:41:40 -0600 )edit