Ask Your Question

Need help with a Gsettings command

asked 2018-11-29 15:54:41 -0500

tablepc gravatar image

I have been slowly building a script of gsettings commands so I can configure PCs to our standard configuration without a lot of scrolling and mouse clicking per PC. Thanks to helpful people in the community I have made progress, but I still have a few that I'm not having any success with.

This one is for setting Notification Preferences. In this example I am trying to turn off notifications from Clocks. I have tried two approaches and variations of the approaches. The command line code for my two trials is below:

gsettings set org.gnome.desktop.notifications.application "org-gnome-clocks" enable false

gsettings set org.gnome.desktop.notifications.application://org/gnome/desktop/notifications/application:/:$(gsettings get org.gnome.desktop.notifications.application default | sed -e s/^\'// -e s/\'$//)/ "org-gnome-clocks" enable false

I've had no luck and will appreciate any help.

Thanks and Have a Great Day!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-11-29 18:27:01 -0500

ed209 gravatar image

Well, using dconf-editor there is no application item under org.gnome.desktop.notification. Nor a gnome-clocks key or similar. I would suggest to search for the clock item before continuing.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-11-29 15:54:41 -0500

Seen: 50 times

Last updated: Nov 29 '18