Ask Your Question
2

Want to stop: packagekit systemd gnome-software

asked 2018-12-01 11:31:49 -0600

lovepump gravatar image

Just like the title reads.

Every time I reboot I have to issue:

sudo systemctl stop packagekit; sudo systemctl disable packagekit

Or my var partition fills up with unwanted fedora 28 and 29 rpms from packagekit/gnome-software.

Something is re-enabling it with every reboot.

I've also read about disabling gnome-software and done so, but I am assuming gnome-software is what I have gotten wrong, given systemd/systemctl should be "in charge".

Can someone help me understand why I can't turn this off?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-12-01 11:57:30 -0600

SteveEbey73701 gravatar image

try sudo systemctl mask packagekit

edit flag offensive delete link more

Comments

Will give it a shot. Any reason why a mask is better than a disable here? Perhaps the shortcut "existing" is enough for gnome-software to leave it alone (or not add it back in)?

lovepump gravatar imagelovepump ( 2018-12-01 16:02:45 -0600 )edit

Good question: 'disable' just prevents a service from being started at startup. Even when a service is disabled, it can be started if some other unit is started that depends on it. You need to do 'mask' if you want to prevent that service from being started in this additional case. There's a nice explanation here: https://fedoramagazine.org/systemd-ma...

bivalence gravatar imagebivalence ( 2018-12-02 09:37:16 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-01 11:31:49 -0600

Seen: 60 times

Last updated: Dec 01 '18