Ask Your Question
0

f29 long shutdown/reboot after nvidia-driver install

asked 2018-12-02 05:12:08 -0600

ulrich gravatar image

Hi everyone, i'm really strugglin to solve this problem and appreciate all the help i can get!

What i did so far:
1. Install F29 Workstation Gnome, UEFI boot (core i5-3570, GeForce GTX 960/NV126)
2. Enabled RPMFusion Repo for nvidia and installed the latests Driver

After that booting up is blazingly fast as always, but shutdown/reboot takes about 4 to 5 minutes.
Shutdown goes like this:
I see the splash screen (plymouth?) for 2 Minutes, then the screen shows some console output for a minute
Then appears a messae like "systemd blah... sending sigkill to Xorg...." which takes another minute or two.
Then the system shuts down.

Is there a way to solve this?

Thanks in advance!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-12-02 09:13:21 -0600

ed209 gravatar image

From a terminal as root enter

shutdown -h now

this will shutdown the machine. Next time it should behave as expected. Sometimes on shutdown there is something that remains waiting, often it can be cleared this way.

edit flag offensive delete link more

Comments

Sorry for answering so late... but that did acutally the trick! Now the system reboots/shuts down as quickly as it should. Thanks!

ulrich gravatar imageulrich ( 2018-12-15 06:16:55 -0600 )edit
0

answered 2018-12-02 09:18:00 -0600

bivalence gravatar image

From watching what happens on my systems, I've noticed there's a job that runs at shutdown to check if you need to compile the nvidia kernel modules. When you install the nvidia drivers (at least the ones from rpmfusion), it doesn't install the kernel modules. It installs a setup that will compile the right kernel nvidia kernel module for your latest kernel, if one doesn't already exist. This happens for me at shutdown after updating the kernel. So you don't want to prevent this; if you don't let it complete, you probably won't have the necessary kernel modules to boot up next time.

edit flag offensive delete link more

Comments

This is not the case as it happens at every shutdown, not only the first one after installing akmod.

ed209 gravatar imageed209 ( 2018-12-02 18:10:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-02 05:12:08 -0600

Seen: 41 times

Last updated: Dec 02