Ask Your Question
0

File conflicts with file from package on fedora 28

asked 2018-12-02 07:48:20 -0600

heyjojo gravatar image

My fedora 28 replace on 64-bit desktop.
After trying to update: dnf update.
I have an error: "Error: Transaction check error" and list of conflicts with message: "conflicts with file from package".
I had same problem on summer but I did nothing and conflicts disappeared. Now I have next:

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/licenses/libcom_err/NOTICE from install of libcom_err-1.44.2-0.fc28.i686 conflicts with file from package libcom_err-1.43.8-2.fc28.x86_64
  file /etc/xattr.conf from install of libattr-2.4.48-3.fc28.i686 conflicts with file from package libattr-2.4.47-23.fc28.x86_64

Error Summary

How to fix it?
Upgrading the system to version 29 will help?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2018-12-02 09:06:11 -0600

bivalence gravatar image

These conflicts are between the i686 version of the packages with the x86_64 versions. One way this can happen is if you have duplicate packages installed (when, for example, dnf crashes during an update). You can check if you have dupes for these packages with:

rpm -q libcom_err libattr

You can run the following to remove duplicates

sudo dnf remove --duplicates

Also, you may no longer need the i686 versions of these packages, and you could just try and remove them to see what happens:

sudo dnf remove libcom_err.i686 sudo dnf remove libattr.i686

(Definitely don't want to pass in the -y in instances like this since these removes may want to remove a lot of important packages, in which case you'll want to cancel the remove ...)

You should fix this before trying to upgrade to Fedora 29.

edit flag offensive delete link more

Comments

This list of error (https://pastebin.com/NwcyaxgP) I have after:

sudo dnf remove --duplicates
heyjojo gravatar imageheyjojo ( 2018-12-08 07:37:47 -0600 )edit
2

answered 2018-12-02 09:07:51 -0600

fcomida gravatar image

Strange. According to bodhi e2fsprogs-1.44.2-0 (which provides libcom_err-1.44.2-0) and attr-2.4.48-3 (which provides libattr-2.4.48-3) are on stable for five months now. I can see from your transaction that the new x86_64 packages cannot be updated. Probably you have a package that depends on libattr-2.4.47 preventing it to be a updated to its newest version. Try dnf repoquery --available --alldeps --whatrequires libattr-2.4.47-23.fc28.x86_64 to see which package depends on this version of libattr.

edit flag offensive delete link more

Comments

Current versions for f28 are:

libattr.i686      2.4.47-23.fc28 fedora 
libattr.x86_64    2.4.47-23.fc28 fedora 
libattr.i686      2.4.48-3.fc28  updates
libattr.x86_64    2.4.48-3.fc28  updates
libcom_err.i686   1.43.8-2.fc28  fedora 
libcom_err.x86_64 1.43.8-2.fc28  fedora 
libcom_err.i686   1.44.2-0.fc28  updates
libcom_err.x86_64 1.44.2-0.fc28  updates
villykruse gravatar imagevillykruse ( 2018-12-02 10:25:40 -0600 )edit

You cannot have both libattr-2.4.47-2 and libattr-2.4.48-3 (i686/x86_64) installed at the same time (the same for libcom_err). That's why the transaction failed. My guess is that some package needs libcom_err-2.43.8-2 (some 3rd party package?). You must find out which is the offending package. I'd download the newest version of libattr and libcom_err from koji and try a local update of those packages. dnf --whatrequires .... or rpm --whatrequires ... have never been reliable or useful in my experience.

fcomida gravatar imagefcomida ( 2018-12-02 12:29:14 -0600 )edit

And the 32-bit and 64-bit version of the package must be the same version number.

rpm -e --test libattr is one way to find the direct dependencies,

villykruse gravatar imagevillykruse ( 2018-12-03 00:36:30 -0600 )edit
1

answered 2018-12-02 09:18:18 -0600

ed209 gravatar image

You should not have both versions of libcom_err as it's not needed. Erase libcom_err-1.44.2-0.fc28.i686 with

dnf remove libcom_err-1.44.2-0.fc28.i686

and check out your repositories in /etc/yum.repos.d . Maybe you have something superfluous there.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-02 07:48:20 -0600

Seen: 33 times

Last updated: Dec 02