Lamobo R1 Switch

asked 2018-12-05 00:49:07 -0600

ralfhs gravatar image

I have installed Fedora Server 29 on a Lamobo (BananaPi) R1. The BananaPi has five Ethernet Connections.I connected the LAN cable to the remote Ethernet port. The BananaPi gets assigned by the FritzBox via DHCP an IP address. I can reach the server cockpit via this IP. I would like to connect to the other four Ethernet ports more devices that should also be assigned by the FritzBox via DHCP IP addresses. The BananaPi should, if I understand correctly, so work as a switch. For this I have activated in the server cockpit at the ports LAN1 to 4 and WAN "Auto Connect", but the devices are assigned no IP. Why?

edit retag flag offensive close merge delete

Comments

Since a DHCP reply is based on the MAC address of the requesting interface, I guess the answer is NO, you cannot have the DHCP sever assign IPs to the client other NICs. You can run a local DHCP server on your BananaPi. To turn your BananaPi into a switch you must enable IP forwarding (i.e. routing) as well:

echo 1 > /proc/sys/net/ipv4/ip_forward

fcomida gravatar imagefcomida ( 2018-12-05 10:02:07 -0600 )edit

How can I enable IP forwarding on the Fedora server? The file /etc/sysctl.conf is empty. I can "net.ipv4.ip_forward = 1" simply write into it?

ralfhs gravatar imageralfhs ( 2018-12-10 07:27:02 -0600 )edit

Yes, that will do it. To confirm: cat /proc/sys/net/ipv4/ip_forward

fcomida gravatar imagefcomida ( 2018-12-10 08:55:30 -0600 )edit

I have IP forwarding turned on, but the devices still do not get IP assigned by DHCP.

ralfhs gravatar imageralfhs ( 2018-12-11 02:13:42 -0600 )edit

Firewall blocking connections?

# firewall-cmd --add-service=dhcp --permanent

# firewall-cmd --reload
fcomida gravatar imagefcomida ( 2018-12-11 10:40:39 -0600 )edit