Ask Your Question
0

Why won't Boxes work?

asked 2018-12-06 07:13:15 -0600

pwd gravatar image

Hi there. This is my first question. I'm quite new to Fedora, but have been using Ubuntu for a long time. On Ubuntu, when I couldn't get Boxes to work, I needed to sudo adduser USERNAME kvm, while I assume that's the issue I'm facing now, I have no idea how to do it on Fedora.

This is what comes up in the troubleshooting information:

Broker URL: qemu+unix:///session
Domain: boxes-unknown
UUID: 519b9889-6ff2-4568-a782-1f50ed825bb7
Persistent: yes
Cpu time: 0
Memory: 8402189 KiB
Max memory: 16331744 KiB
CPUs: 8
State: GVIR_DOMAIN_STATE_SHUTOFF

Domain config:
------------------------------------------------------------
<domain type="kvm">
  <name>boxes-unknown</name>
  <uuid>519b9889-6ff2-4568-a782-1f50ed825bb7</uuid>
  <title>tails-amd64-3</title>
  <metadata>
    <boxes:gnome-boxes xmlns:boxes="https://wiki.gnome.org/Apps/Boxes">
      <os-state>live</os-state>
      <media>/nfs/linuxisos/Tails/tails-amd64-3.9.iso</media>
    </boxes:gnome-boxes>
  </metadata>
  <memory unit="KiB">8402189</memory>
  <currentMemory unit="KiB">8402189</currentMemory>
  <vcpu placement="static">8</vcpu>
  <os>
    <type arch="x86_64" machine="pc-i440fx-3.0">hvm</type>
    <boot dev="cdrom"/>
    <boot dev="hd"/>
  </os>
  <features>
    <acpi/>
    <apic/>
  </features>
  <cpu mode="custom" match="exact" check="partial">
    <model fallback="allow">Haswell-noTSX-IBRS</model>
    <topology sockets="1" cores="4" threads="2"/>
  </cpu>
  <clock offset="utc">
    <timer name="rtc" tickpolicy="catchup"/>
    <timer name="pit" tickpolicy="delay"/>
    <timer name="hpet" present="no"/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <pm>
    <suspend-to-mem enabled="no"/>
    <suspend-to-disk enabled="no"/>
  </pm>
  <devices>
    <emulator>/usr/bin/qemu-kvm</emulator>
    <disk type="file" device="disk">
      <driver name="qemu" type="qcow2" cache="writeback"/>
      <source file="/home/username/.local/share/gnome-boxes/images/boxes-unknown"/>
      <target dev="hda" bus="ide"/>
      <address type="drive" controller="0" bus="0" target="0" unit="0"/>
    </disk>
    <disk type="file" device="cdrom">
      <driver name="qemu" type="raw"/>
      <source file="/nfs/linuxisos/Tails/tails-amd64-3.9.iso" startupPolicy="mandatory"/>
      <target dev="hdc" bus="ide"/>
      <readonly/>
      <address type="drive" controller="0" bus="1" target="0" unit="0"/>
    </disk>
    <controller type="usb" index="0" model="ich9-ehci1">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x7"/>
    </controller>
    <controller type="usb" index="0" model="ich9-uhci1">
      <master startport="0"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x0" multifunction="on"/>
    </controller>
    <controller type="usb" index="0" model="ich9-uhci2">
      <master startport="2"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x1"/>
    </controller>
    <controller type="usb" index="0" model="ich9-uhci3">
      <master startport="4"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x05" function="0x2"/>
    </controller>
    <controller type="pci" index="0" model="pci-root"/>
    <controller type="ide" index="0">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x01" function="0x1"/>
    </controller>
    <controller type="virtio-serial" index="0">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x06" function="0x0"/>
    </controller>
    <controller type="ccid" index="0">
      <address type="usb" bus="0" port="2"/>
    </controller>
    <interface ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-06 11:31:07 -0600

ed209 gravatar image

First of all, upgrade. You have the oldest kernel of F29. Then, your iso cannot be read. See the last three lines? "Permission denied" on tails.iso. Fix it then try again.

edit flag offensive delete link more

Comments

I'm using the newest kernel that's listed on Grub. Could it be older because I have a Nvidia GPU?

pwd gravatar imagepwd ( 2018-12-07 06:59:21 -0600 )edit

I don't see any correlation with those two facts. And it has nothing to do with wrong permissions you didn't fix.

ed209 gravatar imageed209 ( 2018-12-14 18:54:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-12-06 07:13:15 -0600

Seen: 138 times

Last updated: Dec 06