Ask Your Question
1

Upgrading from Fedora 28 to Fedora 29 errors

asked 2018-12-07 23:07:20 -0600

Joe3767 gravatar image

updated 2018-12-08 04:10:03 -0600

hhlp gravatar image

dnf system-upgrade download --refresh --releasever=29 --allowerasing --best Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y Failed to synchronize cache for repo 'updates-testing', disabling. Last metadata expiration check: 0:00:00 ago on Sat 08 Dec 2018 04:03:16 PM AEDT. Error: Problem 1: package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires /usr/bin/python3, but none of the providers can be installed - package python3-3.7.1-4.fc29.i686 requires libpython3.7m.so.1.0, but none of the providers can be installed - package python3-3.7.1-4.fc29.x86_64 requires libpython3.7m.so.1.0()(64bit), but none of the providers can be installed - cannot install the best update candidate for package dnf-2.7.5-12.fc28.noarch - python3-3.6.7-2.fc28.x86_64 does not belong to a distupgrade repository - nothing provides libgdbm.so.6 needed by python3-libs-3.7.1-4.fc29.i686 - nothing provides libgdbm.so.6()(64bit) needed by python3-libs-3.7.1-4.fc29.x86_64 Problem 2: problem with installed package dnf-2.7.5-12.fc28.noarch - package dnf-4.0.9-1.fc29.noarch requires python3-dnf = 4.0.9-1.fc29, but none of the providers can be installed - package python3-dnf-4.0.9-1.fc29.noarch requires python3-rpm >= 4.14.0, but none of the providers can be installed - package python3-rpm-4.14.2.1-2.fc29.x86_64 requires rpm-libs(x86-64) = 4.14.2.1-2.fc29, but none of the providers can be installed - python3-rpm-4.14.2.1-2.fc28.x86_64 does not belong to a distupgrade repository - dnf-2.7.5-12.fc28.noarch does not belong to a distupgrade repository - nothing provides libcrypto.so.1.1(OPENSSL_1_1_1)(64bit) needed by rpm-libs-4.14.2.1-2.fc29.x86_64


Any guidance please?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-08 05:37:07 -0600

Glenn gravatar image

Take a step back. Start with

dnf --enablerepo=updates-testing update python3-dnf

Once complete retry the distribution upgrade.

edit flag offensive delete link more

Comments

Glenn,

Tried that --- response is that there is nothing to do ....

dnf --enablerepo=updates-testing update python3-dnf Last metadata expiration check: 1:26:14 ago on Tue 15 Jan 2019 06:04:08 PM AEDT. Dependencies resolved. Nothing to do.

Complete!

Then I run the dnf upgrade command and still get errors.... Problem: problem with installed package dnf-2.7.5-12.fc28.noarch - package dnf-4.0.4-1.fc29.noarch requires python3-dnf = 4.0.4-1.fc29, but none of the providers can be installed - package dnf-4.0.9-2.fc29.noarch requires python3-dnf = 4.0.9-2.fc2

Joe3767 gravatar imageJoe3767 ( 2019-01-15 02:42:25 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2018-12-07 23:07:20 -0600

Seen: 129 times

Last updated: Dec 08 '18